Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Configure physical switch ports for ESXi hosts

Posted on 2015-02-11
4
Medium Priority
?
996 Views
Last Modified: 2015-02-23
I have 5 ESXi hosts and need to connect them to new Meraki core switches. The hosts connect via multiple 1Gbps ethernet cables to the core switches for user access.

Note: The hosts are on a fiber backbone that connect to QLogic FC switches, which connects to the SAN (so no iSCSI in my environment).

How do I configure the physical switch ports where the esxi hosts are connected?
Trunk or access?

If trunk, will I add every possible VLAN that the host can talk to?
If access, I assume it needs to be in the same VLAN as the vcenter server?

Do I need to change anything on the hosts, vcenter or vsphere once I move the hosts to the new switches?
0
Comment
Question by:Paul Wagner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 123

Assisted Solution

by:Andrew Hancock (VMware vExpert / EE MVE^2)
Andrew Hancock (VMware vExpert / EE MVE^2) earned 750 total points
ID: 40604140
Yes, create a trunk, by adding multiple physical ports together, and then add all the VLANs to that trunk, and then make sure, you add the VLAN numbers to the virtual machine porrgroups.

You need to change the VLAN numbers on he virtual machine portggroups.
0
 
LVL 5

Author Comment

by:Paul Wagner
ID: 40604182
@andrew hancock

virtual machine portgroups - Is that the VLAN I put each VLAN into by changing the NIC or are you talking about adding a virtual network with VLAN assignments to each physical NIC in the configuration tab for each host?
0
 
LVL 5

Accepted Solution

by:
Paul Wagner earned 0 total points
ID: 40613329
So here's a problem I found:

Meraki forces a Native VLAN on each trunk port. (ie- allows vlans 1-20 but native will be 20)

If you have VMs that use VLAN 20, you'll have to make sure that VLAN tagging is blanked out (nothing on that line) in vSwitch properties. You can't tag them with VLAN 20 since the Meraki port already has a native vlan of 20. It's kind of like double tagging the packets.

All other VLANs are OK to leave tagged in vSwitch.
0
 
LVL 5

Author Closing Comment

by:Paul Wagner
ID: 40625341
Andrew, you were partially right. The VMs that operated on the trunk port native vlan (physical switch) had to have their VLAN ID removed from the port group in the vSwitch or else all packets would be double tagged and the switch drop the packets. All other VLAN IDs worked fine.
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
This article outlines why you need to choose a backup solution that protects your entire environment ā€“ including your VMware ESXi and Microsoft Hyper-V virtualization hosts ā€“ not just your virtual machines.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this vā€¦

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question