[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 25
  • Last Modified:

problem forwarding port to desktop

I was asked to forward 2 ports, 50501 to a server and 50502 to a desktop.  I created the rules in the router and setup the rules in windows firewall.  It worked fine for the server, but the desktop doesn't respond.  

Crazy thing is I disabled the rule on the router for the desktop, I checked on canyouseeme.org, it was able to detect the open port.  When I enable the rule on router, the port is no longer detected.

The desktop is running windows 7 pro.

Has anyone experienced this before?  What could be wrong?
0
rrincones
Asked:
rrincones
  • 6
  • 2
  • 2
1 Solution
 
Hypercat (Deb)Commented:
If the Windows firewall is on at the desktop, you may have to open that port in the Windows firewall settings as well. In that case, it would make sense that when you forward that port, it's seen as closed.
0
 
rrinconesAuthor Commented:
I created a rule on windows firewall for the port.  its allowed on all networks.  I even tried disabling the firewall.  The desktop was formatted and windows was reinstalled. no other antivirus or firewall is installed at this moment.
0
 
Stephen BerkCommented:
Check the Nat. I think the cysm port check is probably misleading and not actually getting to the intended desktop. You could post the relevant config info of the router if you want more specific help.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
rrinconesAuthor Commented:
@Stephen Berk.  Why would it work for the server and not the desktop?
0
 
Stephen BerkCommented:
I don't know. I never troubleshoot that way, asking why something is happening now when it didn't happen before. I just take the problem and start troubleshooting. You created two nats or forwarding rules. One works and one doesn't. That's your problem definition. You say that when you disabled the port forward on the desktop, it was still forwarding. That doesn't make sense. Your router won't port forward unless you configure it to. So either the website is mistaken, or you have something misconfigured on the router. Let's assume the latter and have a look at the configuration. At least that's what I'd be interested in looking at. Others may have additional suggestions.
0
 
rrinconesAuthor Commented:
I didn't say it was still forwarding, I stated when I remove the port forwarding rule from the router, the website, canyouseeme.org, states it can see the computer on that port.  When I add it back, the website can no longer detect it.

How do I provide the configuration?  screen shots?
0
 
Hypercat (Deb)Commented:
Please provide the make/model of your router, and also a screen capture of both of the port forwarding rules that you're using for this purpose (server and workstation).
0
 
rrinconesAuthor Commented:
netgear r4500

port forwarding rules
0
 
rrinconesAuthor Commented:
Never received a solution.  Didn't matter in the end we decided not to use that software.
0
 
rrinconesAuthor Commented:
never received a solution for the problem.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now