Solved

default index.cfm document not loading includes

Posted on 2015-02-11
8
164 Views
Last Modified: 2015-02-17
I have a ColdFusion 11 and IIS 7.5 running on Windows 2008 R2 server.  When I load a page (http://mydomain.org/) using the default docment, index.cfm, the page loads but does not display the includes.  If I go to the same page using the full url (http://mydomain.org/index.cfm) the includes load.  This is not a problem when the default document is an html file, index.html loads the includes either way.
0
Comment
Question by:muellertj
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 39

Expert Comment

by:gdemaria
ID: 40604540
when you say it doesn't load the includes, do you mean you have a <CFINCLUDE> tag and the contents of that are not included in the display?   And no error message?   Did you try just putting  <h1>Hello World</h1> inside the top of the include with a CFEXIT to see if it opens the file at all?
0
 

Author Comment

by:muellertj
ID: 40604565
Yes, I have a <cfinclude> tag and the contents do not display when I load the page as the default document. They do load when I load the page using the file name as part of the url.   I do not get any error messages.  I have not tried editing the include files because they load fine when I use the full URL. I think this must be an IIS/CF configuration issue.
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40604722
When you view source when the default page loads.. Do you see strictly html or is it showing cf code too?
0
Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:muellertj
ID: 40604728
when I view it as the default document I see <cfinclude template="includes/header.html">

when I view it as the full url I see the the <cfinclude> content
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40604730
Yea that is what I figured.

I am not sure of the answer just yet.  I need to research but what is happening is iis is not handing off to CF when you do not specify the file name... it is just processing the document as an html file... proven by the fact that you see cf code when viewing source...
0
 
LVL 39

Assisted Solution

by:gdemaria
gdemaria earned 100 total points
ID: 40604946
Oh!   It's not processing ANY coldfusion code, not just the CFINCLUDE.... none of the Coldfusion code is getting processed!

You need to go into IIS and designate / to be processed by Coldfusion.   I contacted Adobe support for Coldfusion on the adobe website and they helped me no charge.   I selected Installation Issue on the support form.    Sorry I wish I could remember how it was fixed exactly, but I am pretty sure it was in IIS.
0
 

Accepted Solution

by:
muellertj earned 0 total points
ID: 40606668
IIS was definitely at fault.  After some searching I checked the Handler Mappings for my website.  I must have changed the cfmHandler for .cfm at some point because the Entry Type was set to Local instead of Inherited.  Everything works after setting it to "revert to parent."
0
 

Author Closing Comment

by:muellertj
ID: 40613832
I was set on the right track gdemaria but ultimately I found the answer on my own.
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
Lease-to-own eliminates the expenditure of hardware replacement and allows you to pay off the server over time. Usually, this is much cheaper than leasing servers. Think of lease-to-own as credit without interest.
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question