?
Solved

Event ID 12

Posted on 2015-02-11
13
Medium Priority
?
95 Views
Last Modified: 2015-03-03
My DC has this in the event log and it never sync's its time with my external time source.

Time Provider NtpClient: This machine is configured to use the domain hierarchy to determine its time source, but it is the AD PDC emulator for the domain at the root of the forest, so there is no machine above it in the domain hierarchy to use as a time source. It is recommended that you either configure a reliable time service in the root domain, or manually configure the AD PDC to synchronize with an external time source. Otherwise, this machine will function as the authoritative time source in the domain hierarchy. If an external time source is not configured or used for this computer, you may choose to disable the NtpClient.
0
Comment
Question by:KineticNetworking
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
13 Comments
 
LVL 24

Expert Comment

by:VB ITS
ID: 40604903
You can configure your PDC emulator to use an external time source using the steps in this article: http://support.microsoft.com/kb/816042

You can opt to use the Fix it or do it yourself. I usually go with the latter as I want to specify what NTP servers I want to use.

As for which NTP servers to use, jump on http://www.pool.ntp.org/en/ and pick servers that are close to you geographically.
0
 

Author Comment

by:KineticNetworking
ID: 40605987
I have already tried this fix and still get this this error.
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40607000
After you implemented the registry keys, did you restart the Windows Time service?

Try running this command in an elevated Command Prompt window and post the output:
w32tm /query /status

Open in new window

0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:KineticNetworking
ID: 40608239
I did restart the time service after the fix.  Here is the result of the command.

C:\Users\Administrator.WCPL>w32tm /query /status
Leap Indicator: 0(no warning)
Stratum: 1 (primary reference - syncd by radio clock)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0000000s
Root Dispersion: 10.0000000s
ReferenceId: 0x4C4F434C (source name:  "LOCL")
Last Successful Sync Time: 2/12/2015 6:59:04 PM
Source: Free-running System Clock
Poll Interval: 6 (64s)
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40611281
OK try running this command:
w32tm /resync /rediscover /nowait

Open in new window

Then run w32tm /query /status afterwards - pay attention to the Source value.
0
 

Author Comment

by:KineticNetworking
ID: 40613423
The Source still says "Free-Running System Clock", which i am assuming is my problem.  The registry has addresses of external time servers so why does this say "Free-Running System Clock"  How do I change this.?

C:\Users\Administrator.WCPL>w32tm /query /status
Leap Indicator: 0(no warning)
Stratum: 1 (primary reference - syncd by radio clock)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0000000s
Root Dispersion: 10.0000000s
ReferenceId: 0x4C4F434C (source name:  "LOCL")
Last Successful Sync Time: 2/16/2015 9:56:40 PM
Source: Free-running System Clock
Poll Interval: 6 (64s)
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40613434
Try running these commands:

NET STOP W32TIME
NET START W32TIME
W32TM /config /reliable:YES
W32TM /resync /rediscover

Open in new window

0
 

Author Comment

by:KineticNetworking
ID: 40614926
Here is my result

C:\Users\Administrator.WCPL>net stop w32time
The Windows Time service is stopping.
The Windows Time service was stopped successfully.


C:\Users\Administrator.WCPL>net start w32time
The Windows Time service is starting.
The Windows Time service was started successfully.


C:\Users\Administrator.WCPL>w32tm /config /reliable:YES
The command completed successfully.

C:\Users\Administrator.WCPL>w32tm /resync /rediscover
Sending resync command to local computer
The computer did not resync because no time data was available.
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40615845
Can you please post the output from this command? w32tm /query /configuration

I have a feeling something has been misconfigured.
0
 

Author Comment

by:KineticNetworking
ID: 40616859
Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Administrator.WCPL>w32tm /query /configuration
[Configuration]

EventLogFlags: 2 (Local)
AnnounceFlags: 5 (Local)
TimeJumpAuditOffset: 28800 (Local)
MinPollInterval: 6 (Local)
MaxPollInterval: 10 (Local)
MaxNegPhaseCorrection: 3600 (Local)
MaxPosPhaseCorrection: 3600 (Local)
MaxAllowedPhaseOffset: 300 (Local)

FrequencyCorrectRate: 4 (Local)
PollAdjustFactor: 5 (Local)
LargePhaseOffset: 50000000 (Local)
SpikeWatchPeriod: 900 (Local)
LocalClockDispersion: 10 (Local)
HoldPeriod: 5 (Local)
PhaseCorrectRate: 7 (Local)
UpdateInterval: 100 (Local)


[TimeProviders]

NtpClient (Local)
DllName: C:\Windows\system32\w32time.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)
CrossSiteSyncFlags: 2 (Policy)
AllowNonstandardModeCombinations: 1 (Local)
ResolvePeerBackoffMinutes: 15 (Policy)
ResolvePeerBackoffMaxTimes: 7 (Policy)
CompatibilityFlags: 2147483648 (Local)
EventLogFlags: 0 (Policy)
LargeSampleSkew: 3 (Local)
SpecialPollInterval: 3600 (Policy)
Type: NT5DS (Policy)

NtpServer (Local)
DllName: C:\Windows\system32\w32time.dll (Local)
Enabled: 1 (Local)
InputProvider: 0 (Local)
AllowNonstandardModeCombinations: 1 (Local)

VMICTimeProvider (Local)
DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40630577
Is it possible that your router is blocking NTP?  You need to have port 123 on your router open in both directions for TCP and UDP in order to be able to sync with an outside time source.
0
 

Accepted Solution

by:
KineticNetworking earned 0 total points
ID: 40633513
We found a Group Policy setting in the Default Domain Policy that someone must of setup that was overriding the settings that we were changing.  Thanks for all the suggestions.
0
 

Author Closing Comment

by:KineticNetworking
ID: 40641607
We found a GPO in our domain default policy that was overriding the changes we were making.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
New style of hardware planning for Microsoft Exchange server.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question