Solved

AutoHot Key ctrl not working

Posted on 2015-02-11
3
227 Views
Last Modified: 2015-02-12
Hi, I have just run across something very peculiar.  For the last three months I have been using Autohot Keys to write scripts to use as shortcuts.  Here is an example;
;This is to open Microsoft Outlook
^e::
Run, C:\Program Files (x86)\Microsoft Office\Office14\Outlook.exe
Return

Here, the inverted v (represents the ctrl key which is one of the modifiers allowed by AHK.  Holding down the ctrl key while pressing the "e" key opens Outlook so that I can see my emails,  

I when in to add a script today and pressed the ctrl key and NOTHING happened.  No symbol of any kind so I could not complete my script.  My notebook (Envy 15 t) is only a week old so I can't figure out if the ctrl key just quit working or if there might be something else going on.  All of the scripts that I have written use the ctrl key as a modifier and they all work perfect so I don't understand why it will no longer work.

Let me say that everything was created on another Windows 7 laptop and transferred to this one so I don't know if that has something to do with it or not.  In the event I can not get this key to work, is there another way to write the ctrl command other than hitting the ctrl key?  If so, could you please give me an example. Thanks
0
Comment
Question by:camtz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 53

Accepted Solution

by:
Joe Winograd, EE MVE earned 500 total points
ID: 40605568
You don't hit the Ctrl key to get ^ in your AutoHotkey scripts. You hit Shift-6 on your keyboard. That enters ^ in the source code file (which is plain text). When AHK executes and sees the ^ in your script, it interprets it as the Ctrl key. I suppose the location of ^ could be different from Shift-6 on your keyboard (depends on Region/Language setting), but I know that Shift-6 is its location on the US and UK keyboards. Your EE profile says you're in the US, so that's probably where it is, but if hitting Shift-6 doesn't give you the ^ character, then look for ^ on your keyboard. Regards, Joe
0
 

Author Closing Comment

by:camtz
ID: 40605625
Excelente !!!! - You are absolutely correct.  I just cheit and it works.  I suppose that it's been a long time since I did this and had forgotten.  Thanks again
0
 
LVL 53

Expert Comment

by:Joe Winograd, EE MVE
ID: 40605672
You're welcome. Happy to help. Also, note that the situation is similar for the Alt key in AutoHotkey. If you have the Alt key in any of your AHK scripts, you'll see the exclamation mark (!), which AHK interprets as the Alt key. For example, if your script wants to enter Alt-F to get the File menu in a program, you'll see !f in your AHK script. To get the ! character in your script, hit Shift-1 on your keyboard (similar to hitting Shift-6 on your keyboard to get the ^ character in your script). Regards, Joe
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A short article about a problem I had getting the GPS LocationListener working.
A short article about problems I had with the new location API and permissions in Marshmallow

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question