Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Unable to send into a specific external email domain - Delivery is delayed to these recipients or groups ?

Posted on 2015-02-12
14
Medium Priority
?
418 Views
Last Modified: 2015-06-23
When I tried to send email to a specific email domain from my company to external emal address, it is not getting through on the same day.
Instead i get this error message:

Delivery is delayed to these recipients or groups:
This message hasn't been delivered yet. Delivery will continue to be attempted.

I can see that there is no problem with Exchange Server 2010 email queue or any other email domain, but just to this one and some other ones.

So how can I verify that it is not our email infrastructure problem ?

Where to start for the troubleshooting ?
0
Comment
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +2
14 Comments
 
LVL 7

Assisted Solution

by:Deadman
Deadman earned 500 total points
ID: 40607343
Check your server is blacklisted here and also check your event viewer system and application log for Exchange related warnings and or errors.

And also check there might be a problem by the receiver end or recepient. If the message cannot be delivered within 48 hours you will receive an error message why the mail is not delivered.
You can take lead from that error message to resolve this issue.

Is there recently any changes made in public dns hosting?
0
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 40607366
I have verified that both sides of email server is not black listed from MXToolbox website.
0
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 40607367
Public DNS ?
On which side do you mean ?
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 7

Expert Comment

by:Deadman
ID: 40607375
any changes made in Public DNS or web hosting at your end
0
 
LVL 4

Assisted Solution

by:Manoj Bojewar
Manoj Bojewar earned 500 total points
ID: 40607412
Please do one more thing,

Telnet mx record (IP address)  of any domain from exchange hub/Edge server which mails getting delay and see you are able to connect or getting any banner error message.
0
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 40607523
Hi manoj,

How do I do it if I don't know the name of the email server on the target email domain ?
0
 
LVL 13

Assisted Solution

by:Guy Lidbetter
Guy Lidbetter earned 1000 total points
ID: 40612310
Have you seen these emails being delayed in your own Queue viewer?

Are they being delivered eventually or not at all?

A few points to check:
Make sure you have a pointer record for your mail domain (I.E. a reverse lookup of your external IP address provides the same domain name you are sending from)
You are not using a smarthost that is causing the delay (Message labs externally or ironports internally)
0
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 40612850
Guy,

There is no email queue at all on the Hub servers.

I also using smarthost internally with Symantec bright mail or Mail security virtual appliance. It is not classified as spam I've checked that also.

I'm not sure and still puzzled as to why only to this domain not delivered while the rest of the world is ok.
0
 
LVL 13

Expert Comment

by:Guy Lidbetter
ID: 40613592
Are you receiving and NDR eventually or is it going through after an extended delay?
0
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 40613624
After some times so it is not instant.
0
 
LVL 13

Accepted Solution

by:
Guy Lidbetter earned 1000 total points
ID: 40614077
Then I'm guessing you need to check your smart host queues to see if they are delaying delivery.. alternatively it may be the client side causing mailbox delivery delay.

Either way you need to check the transport logs\queues on the smarthosts.

Can you provide the full error message you do receive?
0
 

Expert Comment

by:subhash pawar
ID: 40844739
hi
 
 I am facing the delivery delayed issue when we send mail to external domain email .
Please suggest me on this issue

when i check the delivery error in  queue viewer its showing 4.7... like error
0
 

Expert Comment

by:subhash pawar
ID: 40844742
I am using exchange 2010 on server 2012
0
 
LVL 13

Expert Comment

by:Guy Lidbetter
ID: 40846338
@subhash pawar : Please log another ticket with more info regarding your issue. This thread is closed.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One-stop solution for Exchange Administrators to address all MS Exchange Server issues, which is known by the name of Stellar Exchange Toolkit.
The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question