Solved

Evernt Id 1033 Windows 2008 Server w/Exchange 2010

Posted on 2015-02-13
22
2,908 Views
Last Modified: 2015-03-13
Exchange 2010 SP3 RU8 Enterprise  64 bit
Windows 2008 R2 64 bit
IIS 7

Every so often I get Event Id 1033 about 20 of them or so

Here is a sample

Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting MinGALSearchLength in the Web.Config file was not valid. The previous value was null and has been changed to 4.

Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting BootstrapMailDeliveryDelay in the Web.Config file was not valid. The previous value was null and has been changed to 259200.


Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting BootstrapMailDeliveryDelay in the Web.Config file was not valid. The previous value was null and has been changed to 259200.

Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting BootstrapMailDeliveryDelay in the Web.Config file was not valid. The previous value was null and has been changed to 259200.

Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting MaxNumOfFolders in the Web.Config file was not valid. The previous value was null and has been changed to 1000.

Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting MaxNumOfFolders in the Web.Config file was not valid. The previous value was null and has been changed to 1000.

Type :            Warning
Date :            2/13/2015
Time :            5:30:09 PM
Event :            1033
Source :            MSExchange ActiveSync
Category :      Configuration
User :            N/A
Computer :      TGCS025.our.network.tgcsnet.com
Description:
The setting MaxNumOfFolders in the Web.Config file was not valid. The previous value was null and has been changed to 1000.

Why is the web.config file changing its defaults?

I checked the web.config file and the setting match this

Thoughts?
0
Comment
Question by:Thomas Grassi
  • 16
  • 3
22 Comments
 
LVL 53

Accepted Solution

by:
Will Szymkowski earned 500 total points
ID: 40609215
I would take a look at the following technet and follow the steps to help resolve this issue.
http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=8.0&EvtID=1033&EvtSrc=MSExchange+ActiveSync

Will.
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40609219
I saw that article before but I will try it again

Thanks
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40609259
Guys

Found two Keys missing from the web.config file

MinGalSearchLength

MaxNoOfItemsMove

Added both

reset IIS

Lets see if this fixes it

Thanks will monitor this  and will post results
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40610187
Guys

Update

They appeared again today!!!!!!
Any other ideas?
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40612551
Will

Got these two again today

MinGalSearchLength

 MaxNoOfItemsMove


They are missing again

When I add them restart IIS they seem to disappear again after time.

I IIS Application Settings I see no place to save configuration.

Is the web.config file not getting updated?


Thoughts
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40617914
Guys

Still getting this

Is it possible that web.config file does not have proper file permissions?

The article does not help at all.

Also The two I listed above keep disappearing?

Help please this is getting very frustrating.
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40627283
Guys

This fixed the problem

http://www.eventid.net/display-eventid-1033-source-MSExchange%20ActiveSync-eventno-11120-phase-1.htm


From a Microsoft support engineer: "If this is not a partner-hosted environment, you can safely ignore this error. It is simply a warning that the ExternalProxy setting is not set in the web.config. We use a default value of null when we find this.

 If you are not partner hosted and want to get rid of the warning, add a key under the <appSettings> key in your \Program Files\Microsoft\Exchange Server\V14\ClientAccess\Sync\web.config file:
 <add key="ExternalProxy" value=""></add>

 The warning should have only been appearing when the application pool was recycled and just spinning up.  You will need to either recylce the MSExchangeSyncAppPool or do an iisreset and then check your application log. You should no longer see the event."



After I added  <add key="ExternalProxy" value=""></add>  to the web.config file

Restarted IIS and have not seen this message 1033 for 3 days now.
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40637480
I've requested that this question be closed as follows:

Accepted answer: 0 points for trgrassijr55's comment #a40627283
Assisted answer: 500 points for Will Szymkowski's comment #a40609215

for the following reason:

Will

Thanks for your help on this one

Have you had a chance to look at my 16022 event  issue?
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40636461
Will


This is still happening

Please help
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40637149
Will

Last night I went to the Exchange folder on the server and added the domain administrator to the permissions gave it full rights  I only had the local administrator with folder permissions. I logon to the server with a domain administrator account not a local account.

Wondering if this is a permissions thing with web.config not really getting updated.

Thougts
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40640103
Will

Question

Do we know what triggers this event to occur?

It is very random now.

It can go for days without then bang it happens again.

What can I look for?

I found this in another article

This is another web.config file in folder d:\program files\Microsoft\exchange server\v14\clientaccess\ecp

This is different than the one in d:\program files\Microsoft\exchange server\v14\clientaccess\sync


Immediately after <appSettings> and ahead of <!-- Set LogPerformanceData to "true" to log ECP's performance records to the IIS log: -->as shown below
 
 <appSettings>
 
    <add key="BootstrapCABForWM61HostingURL" value="http://go.microsoft.com/fwlink/?LinkId=150061" />
     <add key="MobileUpdateInformationURL" value="http://go.microsoft.com/fwlink/?LinkId=143155" />
     <add key="MaxNumOfFolders" value="1000"></add>
     <add key="NumOfQueuedMailboxLogEntries" value="15"></add>
     <add key="MaxSizeOfMailboxLog" value="8000"></add>
     <add key="ADCacheRefreshInterval" value="60"></add>
     <add key="EventQueuePollingInterval" value="2"></add>
     <add key="MaxRetrievedItems" value="100"></add>
     <add key="MaxWindowSize" value="100"></add>
     <add key="DeviceClassCacheMaxStartDelay" value="21600"></add>
     <add key="DeviceClassCacheMaxADUploadCount" value="300"></add>
     <add key="DeviceClassCachePerOrgRefreshInterval" value="10800"></add>
     <add key="DeviceClassPerOrgMaxADCount" value="1000"></add>
     <add key="DeviceClassCacheADCleanupInterval" value="90"></add>
     <add key="DisableCaching" value="false"></add>
     <add key="SyncLogEnabled" value="true"></add>
     <add key="SyncLogDirectory" value=""></add>
     <add key="SchemaDirectory" value=""></add>
     <add key="SchemaValidate" value="On"></add>
     <add key="BlockNewMailboxes" value="false"></add>
     <add key="BlockLegacyMailboxes" value="false"></add>
     <add key="ProxyVirtualDirectory" value="/Microsoft-Server-ActiveSync"></add>
     <add key="BackOffThreshold" value="3"></add>
     <add key="BackOffTimeOut" value="60"></add>
     <add key="BackOffErrorWindow" value="60"></add>
     <add key="ProxyHandlerLongTimeout" value="3600"></add>
     <add key="ProxyHandlerShortTimeout" value="120"></add>
     <add key="ProxyConnectionPoolConnectionLimit" value="100"></add>
     <add key="MaxCollectionsToLog" value="100"></add>
     <add key="MaxWorkerThreadsPerProc" value="10"></add>
     <add key="MaxRequestsQueued" value="500"></add>
     <add key="MaxMailboxSearchResults" value="100"></add>
     <add key="MailboxSearchTimeout" value="30"></add>
     <add key="MailboxSearchTimeoutNoContentIndexing" value="90"></add>
     <add key="MaxClientSentBadItems" value="4"></add>
     <add key="BadItemIncludeStackTrace" value="false"></add>
     <add key="BadItemIncludeEmailToText" value="false"></add>
     <add key="BadItemEmailToText" value=""></add>
     <add key="MaxGALSearchResults" value="100"></add>
     <add key="MaxDocumentLibrarySearchResults" value="1000"></add>
     <add key="MaxDocumentDataSize" value="10240000"></add>
     <add key="ADCacheExpirationTimeout" value="360"></add>
     <add key="ADCacheMaxOrgCount" value="50000"></add>    
    <add key="FullServerVersion" value="false"></add>
     <add key="BootstrapMailDeliveryDelay" value="259200"></add>

    <!-- Set LogPerformanceData to "true" to log ECP's performance records to the IIS log: -->



Thoughts
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40640146
Because of your original messages
Found two Keys missing from the web.config file

Make me think there are still other underlying issues or missing entries. It might be in your best interest to re-create the web config or check a standard installation for exact entries that are required by default.

Will.
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40640156
Just recreate the section above entries correct?
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40640177
Yeah, i am not sure why you are getting all of these error messages to begin with. I think there might be other underlying issues with your server if default values were missing from Web.Config.

Will.
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40640194
Will

I ran system health
and only a few minor items listed related to out dated drivers for the server and some performance items where the tmp folders are located.

I can run it again and list it if you think that would help?

Do you have a copy of web.config that is good that you can post?
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40640740
Will

Here is the systemhealth report

VERBOSE: Connected to TGCS025.our.network.tgcsnet.com.
[PS] C:\Windows\system32>Add-PsSnapin Microsoft.Exchange.Management.Powershell.E2010
[PS] C:\Windows\system32>get-pssnapin


Name        : Microsoft.PowerShell.Diagnostics
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains Windows Eventing and Performance Counter cmdlets.

Name        : Microsoft.WSMan.Management
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets (such as Get-WSManInstance and Set-WSManInstance) that a
              re used by the Windows PowerShell host to manage WSMan operations.

Name        : Microsoft.PowerShell.Core
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets used to manage components of Windows PowerShell.

Name        : Microsoft.PowerShell.Utility
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains utility Cmdlets used to manipulate data.

Name        : Microsoft.PowerShell.Host
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets (such as Start-Transcript and Stop-Transcript) that are
              provided for use with the Windows PowerShell console host.

Name        : Microsoft.PowerShell.Management
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains management cmdlets used to manage Windows components.

Name        : Microsoft.PowerShell.Security
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets to manage Windows PowerShell security.

Name        : Microsoft.Exchange.Management.Powershell.E2010
PSVersion   : 1.0
Description : Admin Tasks for the Exchange Server



[PS] C:\Windows\system32>test-systemhealth -adcredentials $c -verbose | fl


VERBOSE: [23:18:36.591 GMT] Test-SystemHealth : Initializing Active Directory server settings for the remote Windows
PowerShell session.
VERBOSE: [23:18:36.595 GMT] Test-SystemHealth : Active Directory session settings for 'Test-SystemHealth' are: View
Entire Forest: 'False', Default Scope: 'our.network.tgcsnet.com', Configuration Domain Controller:
'tgcs012.our.network.tgcsnet.com', Preferred Global Catalog: 'tgcs011.our.network.tgcsnet.com', Preferred Domain
Controllers: '{ tgcs011.our.network.tgcsnet.com }'
VERBOSE: [23:18:36.595 GMT] Test-SystemHealth : Runspace context: Executing user: our.network.tgcsnet.com/Users/Thomas
R. Grassi Jr, Executing user organization: , Current organization: , RBAC-enabled: Enabled.
VERBOSE: [23:18:36.596 GMT] Test-SystemHealth : Beginning processing &
VERBOSE: [23:18:36.601 GMT] Test-SystemHealth : Instantiating handler with index 0 for cmdlet extension agent "Admin
Audit Log Agent".
VERBOSE: [23:18:36.610 GMT] Test-SystemHealth : Current ScopeSet is: { Recipient Read Scope: {{, }}, Recipient Write
Scopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient Scope(s):
 {}, Exclusive Configuration Scope(s): {} }
VERBOSE: Testing System Health.
VERBOSE: [23:18:40.530 GMT] Test-SystemHealth : Resolved current organization: .

WARNING: The PowerShell virtual directory 'PowerShell-Proxy (Default Web Site)' has been configured to require SSL.
This can cause the Exchange Management Tools to fail to connect.

WARNING: The path for the PowerShell virtual directory 'PowerShell-Proxy (Default Web Site)' has been changed to
'D:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell-Proxy'. This can cause the Exchange Management
Tools to fail to connect. The expected path is 'D:\Program Files\Microsoft\Exchange
Server\V14\ClientAccess\PowerShell'.

WARNING: Storage driver file 'c:\windows\system32\drivers\vhdmp.sys' for 'Microsoft VHD HBA' on server
TGCS025.our.network.tgcsnet.com is more than two years old. Check with your vendor to find out if a newer version is
available. Installed driver details: 6.1.7601.17514 - 20101120222400.162444-300

WARNING: Storage driver file 'c:\windows\system32\drivers\megasas.sys' for 'DELL PERC 6/i Integrated RAID Controller'
on server TGCS025.our.network.tgcsnet.com is more than two years old. Check with your vendor to find out if a newer
version is available. Installed driver details: 4.5.1.64 - 20090713214804.521663-240

WARNING: More than one network interface on server TGCS025.our.network.tgcsnet.com has a default IP gateway listed.
Communication errors may occur if these network connections link to independent subnets.

WARNING: Network interface driver file 'c:\windows\system32\drivers\bxnd60a.sys' for 'l2nd' on server
TGCS025.our.network.tgcsnet.com is more than two years old. Check with your vendor to find out if a newer version is
available. Installed driver details: 4.8.4.0 - 20090610163426.409397-240

WARNING: Network interface driver file 'c:\windows\system32\drivers\bxnd60a.sys' for 'l2nd' on server
TGCS025.our.network.tgcsnet.com is more than two years old. Check with your vendor to find out if a newer version is
available. Installed driver details: 4.8.4.0 - 20090610163426.409397-240

WARNING: Network interface driver file 'c:\windows\system32\drivers\asyncmac.sys' for 'AsyncMac' on server
TGCS025.our.network.tgcsnet.com is more than two years old. Check with your vendor to find out if a newer version is
available. Installed driver details: 6.1.7600.16385 - 20090713201013.139624-240

WARNING: The TEMP path on server TGCS025.our.network.tgcsnet.com is located on the same drive as the system partition.
This may cause performance problems. Current TEMP path: %SystemRoot%\TEMP.

WARNING: The TMP path on server TGCS025.our.network.tgcsnet.com is located on the same drive as the system partition.
This may cause performance problems. Current TMP path: %SystemRoot%\TEMP.

WARNING: Active Directory server tgcs012.our.network.tgcsnet.com is down or unreachable. This error could also be the
result of a network or permissions problem. Error: Access denied

WARNING: Active Directory server tgcs012.our.network.tgcsnet.com is down or unreachable. This error could also be the
result of a network or permissions problem. Error: Access denied

VERBOSE: [23:19:15.062 GMT] Test-SystemHealth : Admin Audit Log: Entered Handler:OnComplete.
VERBOSE: [23:19:15.064 GMT] Test-SystemHealth : Ending processing &
[PS] C:\Windows\system32>



Thoughts
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40650306
Will

This just happened again

What is up with this version of exchange so buggy
0
 
LVL 23

Author Comment

by:Thomas Grassi
ID: 40660054
Will

I think the 1003 messages appear after this runs

@echo off
del c:\util\EASDeviceStats.csv
cd\util
PowerShell.exe -PSConsoleFile "D:\Program Files\Microsoft\Exchange Server\V14\Bin\ExShell.psc1" -Command "./EASDevicestats.ps1"
exit

Open in new window


Which is this

$ResultArr =@()
 $CASMailboxes = Get-CASMailbox -ResultSize Unlimited | ? {$_.HasActiveSyncDevicePartnership -eq $true}
 foreach ($CASMailbox in $CASMailboxes)
 {
 
$ResultArr += Get-ActiveSyncDeviceStatistics -Mailbox $CASMailbox.Identity | Select @{Name=”User”;Expression={($CASMailbox.Name).ToString()}},DeviceType,DeviceModel,FirstSyncTime,LastSuccessSync,IsRemoteWipeSupported
 }
 $ResultArr | Export-Csv C:\util\EASDeviceStats.csv -NoTypeInformation
Send-MailMessage -From “no-reply@tgcsnet.com” -To “support@mydomain.com” -Subject “ActiveSync User Stats” -Attachments C:\util\EASDeviceStats.csv  -Body ” This is an autogenerated Email. Please do not respond to this email” -SmtpServer “serv025.FQDN”
 

Open in new window

0
 
LVL 23

Author Closing Comment

by:Thomas Grassi
ID: 40664512
Not Resolved

Found cause need solution will open new question shortly
0

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
how to add IIS SMTP to handle application/Scanner relays into office 365.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now