Shared Calendar Appointments not appearing for a user with "Owner" permissions

Two receptionists both have access to a user calendar created solely for booking out time slots in a meeting room.
Both have been assigned full access permissions over the mailbox through Exchange.
Both have been assigned Owner permissions within their Outlook profiles over the calendar for the mailbox.

Was working as you would would expect. Both could see existing appointments and could add new ones.

This has now stopped working for one of the receptionists. She is still able to add appointments but they don't show up when viewing the calendar from her Outlook. However, they show up as normal in the second receptionist's Outlook.

I have uninstalled Outlook 2010, and given her Outlook 2013. This resolved the issue for a day or two before the problem resurfaced.

Any ideas??
DataquestukAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
VB ITSConnect With a Mentor Specialist ConsultantCommented:
Have you tried simply removing the calendar (switch to the Calendar view in Outlook, right click on the shared calendar, click Delete Calendar) then re-adding it?

If that doesn't resolve the issue then you can perhaps look at disabling the caching of shared folders within Outlook:

- In Outlook click on File
- Click Account Settings then Account Settings again
- Click Change in the E-mail tab
- More Settings...
- Advanced tab
- Untick Download shared foldersDisable-Caching-of-Shared-Mailboxes.png
- OK your way out when done
0
 
DataquestukAuthor Commented:
The cache disable looks to have fixed it. Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.