Solved

Problem opening Office 365 (Access) with MDB file extension

Posted on 2015-02-16
28
611 Views
Last Modified: 2015-02-18
I can't get Office 365 to recognize my databases which have an MDB extension.
If I open Access and then browse to the MDB file - no problem.
0
Comment
Question by:DAveB_LDS
  • 13
  • 13
  • +1
28 Comments
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40613520
Are you using Click to Run Access or do you have full Office Pro installed?
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40614514
Try the simplest solution first:

Right-click on the problem .mdb file.

Select "Open With", and then click on "Choose Default Program."

You will see recommended Programs, look for Access and select it if found.

If Access isn't listed in the Recommended Programs section, click the Browse button, browse to and select msaccess.exe, and then click Open.
0
 

Author Comment

by:DAveB_LDS
ID: 40614515
Full Office Pro
0
 

Author Comment

by:DAveB_LDS
ID: 40614517
Actually Office 365
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40614535
It sounds exactly like a file association issue. Doing what I suggested should correct it automatically.
0
 

Author Comment

by:DAveB_LDS
ID: 40614549
Before I posted this problem I tried all of those solutions. Even if I browse to MSAccess it doesn't change it.
I also go to Control Panel and attempt to change the file association for MSACCESS to MDB it doesn't accept the change.
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40614555
What exactly happens when you try to open it? Are there any error messages?
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40614574
Another thing you can try is removing the registry entry for the .mdb extension and having the system re-create it. Before deleting it though, look at the keys under it and see what the association is.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.mdb

In the OpenWith folder in the key, it should list MSAccess.exe
0
 

Author Comment

by:DAveB_LDS
ID: 40614576
I can open the MDB if I open MSAccess first. No problem. If I click open with I can browse to MSACCess, highlight it and click okay. It does not change the association which is set at "Office XML Handler". Therefore the MDB does not open
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40614583
Go into the registry and change it in there as I showed or simply delete the one there then use the right-click-open-with method and see if that sticks.
0
 

Author Comment

by:DAveB_LDS
ID: 40614590
Thank you for your help. I have to go to  a client now. Will continue later.
0
 
LVL 37

Expert Comment

by:Gerwin Jansen
ID: 40615132
Did the association ever work or did it stop working at some point?

You could try repairing Office365 from Programs and Features, there should be Quick Repair (which is quicker), or Online Repair.
0
 

Author Comment

by:DAveB_LDS
ID: 40615368
It never worked
The MDB extension points to Office XML Handler
I have tried to change the extension association in Control Panel\Default Program Extensions which is basically the registry. It does not change
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40616443
Could you please try this:

Open a command prompt by clicking on run and typing "cmd"  <enter>

At the prompt, type in the following:

assoc |more    (the vertical line is called a pipe and is the one above the backslash)

It will display all the file associations one page at a time. Hit the space bar or enter to go to the next screen and continue until you reach the .mdb one. What does it show there?
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 30

Expert Comment

by:flubbster
ID: 40616452
Actually, it will be easier to just use the following:

assoc .mdb

this will show just the association for the mdb file type
0
 

Author Comment

by:DAveB_LDS
ID: 40616478
Association not found for .mdb
0
 

Author Comment

by:DAveB_LDS
ID: 40616501
I researched assoc and entered the following command
.mdb=Access.mdbfile

Access is denied
Error occurred while processing .mdb
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40616559
Very strange. Command prompt again. I don't have Office 365 which is Office 2013, but I think this is correct. Type the following:

CD C:\Program Files (x86)\Microsoft Office\Office15  

(This can be verified first by simply navigating to the correct location first to see if it is office 15, if not, change the number accordingly.)

Once in the correct folder, type this in:

msaccess /r

then

msaccess /regserver

test
0
 

Author Comment

by:DAveB_LDS
ID: 40616600
The /r option came back with MSAccess doesn't recognize the command and then open up

The /regserver command opened up Access
0
 
LVL 30

Accepted Solution

by:
flubbster earned 500 total points
ID: 40616616
Open regedit from the run box

navigate here:

HKLM\software\classes\.mdb

click on the entry

What is shown in the right-side window?

It should be:

Access.Application.15   (depending on version)
application/msaccess


If you do the same for .docx or .doc, you should see this:

Winword.Application.15
application/winword
0
 

Author Comment

by:DAveB_LDS
ID: 40616620
Looking in Control Panel /Default Programs/Set Associations
The current default is "Application Unknown"
The same thing that I see when I look at "Set association for a program"
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40616625
You should be able to browse to msaccess to set the default application even if it is not listed
0
 

Author Comment

by:DAveB_LDS
ID: 40616770
I can browse to it, but when I click "open" it does not change.
I have a feeling that it is some kind of permissions issue.
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40616799
I agree. Especially with the access denied message. Did you do the regedit thing? If so, what did you find?

At this point you may just want to do a full re-install, but not by just using add/remove programs. Here is what to do:

Firszt, go into add/remove programs and verify that office 365 is the ONLY office program showing. If it is, great. If it is NOT, then uninstall the other program (most likely a trial one).

Once you know the only thing installed is Office 365, do the following.

Download and run the Office 365 removal tool. This works extremely well as it resets permissions and removes every trace of office.

http://go.microsoft.com/?linkid=9815935

It takes several minutes to run to completion and will open a "dos box" as it is running. Completely normal so just be patient.

Now, Office 365 allows up to 5 installs I believe. After it is completely removed and you have re-booted, log in to your Office live account. You will see your computer listed as one of the systems it is installed on (or the only system). You can de-activate the license for your PC if you want because it is now gone. Or you can just click on the install button again. I would remove the activation so you still have 4 left.

Install it and let's see what happens.
0
 

Author Closing Comment

by:DAveB_LDS
ID: 40616905
Thank you very much for your help.
I really thought it was a Windows issue not Office.
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40617153
You are very welcome. I'm curious... did you do the removal and install or change the registry?
0
 

Author Comment

by:DAveB_LDS
ID: 40617174
Used the removal tool. Previously I worked in the registry with no success.
I think it was definitely permissions, otherwise I would have been able to change control panel
0
 
LVL 30

Expert Comment

by:flubbster
ID: 40617184
Excellent. Glad it is working.

Take care
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

948 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now