Solved

Server 2012 RD Licensing mode is not configured

Posted on 2015-02-17
5
971 Views
Last Modified: 2015-02-17
Hi,

I have installed a brand new Server 2012r2 to be used a remote desktop server.
I have a second server that has the licensing function.

Whenever I log in as administrator the message "Remote Desktop licensing mode is not configured" keeps popping up.
pop up error message licensing
I have installed the Remote Desktop Services Connection broker and used deployment properties to set the licensing server. It is configured as "Per User" and the correct server is set.

If I use Get-RdlicensingConfiguration in powershell it also gives me the correct licensing server.

Should I be worried after the grace period is over that users wont be able to logon?

Thanks in advance,

Joachim
0
Comment
Question by:Itxx
  • 2
  • 2
5 Comments
 
LVL 57

Expert Comment

by:Cliff Galiher
ID: 40613683
You should be concerned. Does your RDCB server have the RDSH server added as a part of the deployment? That is the first common mistake I see.
0
 
LVL 1

Author Comment

by:Itxx
ID: 40613721
Yes, it is only one server. Maybe I'm doing something wrong.
I have just tried removing the Remote Desktop features and installing it again.

I used Add roles and Features and installed Remote Desktop Services including Connection Broker, Licensing & Session Host.
Afterwards I've ran the wizard again and used Remote Desktop Services installation -> Standard deployment -> Session-based desktop deployment and install the RD Connection Broker server.

Then I edited the deployment properties and installed the licensing server.
0
 
LVL 36

Accepted Solution

by:
Mahesh earned 500 total points
ID: 40613751
Please logon to licensing server and locate below reg key
HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period

Delete any values present in this folder except default value
If you face any issues, take ownership of that registry key and assign you full control and then delete all values
Then reboot the server and check if it works

If still it fails, you need to enter licensing server manually on RD licensing server
From elevated PowerShell Prompt run below commands

$LSServer = gwmi -Namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting
$LSServer.GetSpecifiedLicenseServerList()

Open in new window


The above command will tell you if any licensing server is registered, if found none

Run below command
$LSServer.SetSpecifiedLicenseServerList("Licenseserver.domain.com")

Replace server name with yours

Then reboot the server and see if it works
Original article:
http://www.blackforce.co.uk/2014/02/17/2012-rds-server-the-remote-desktop-session-host-server-does-not-have-a-remote-desktop-license-server-specified
0
 
LVL 1

Author Comment

by:Itxx
ID: 40613781
That worked for me!

I didn't have the GracePeriod registry but running the Powershell commands fixed it for me.

Many many thanks.
0
 
LVL 36

Expert Comment

by:Mahesh
ID: 40614225
Ya, that's true, some has found GracePeriod Registry \ some not, however forcing license server through PowerShell fix the issue most of the time.

Thanks
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every now and then, Microsoft does something that totally impresses me. It doesn't happen often, but in this case I must say I am thoroughly impressed with Windows Server Backup. One of the long time issues with Windows Backup has been the ability t…
What to do when Windows Update is not working correctly? What tools can I use to detect the cause of the malfunction problem? What does this numeric error code mean? These and other questions that you have been asking in the past are answered here (…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question