Solved

Managing SSH connection close timeout after password prompt and eliminating initial password prompt delay.

Posted on 2015-02-17
7
329 Views
Last Modified: 2015-02-21
I want to connect  to remote host using
ssh XXX.XXX.XXX.XXX -l root -p XXXX

It's takes 30 seconds to prompt password in Ubuntu (as an opposite, putty client almost immediately asks password), how to eliminate initial password prompt delay?
Also, after  password promopt, it waits only 30 seconds for input, then saying connection close. How to make it 1 hour?

If you unite this two behaviours, you will decide that it's pretty much unefficient. because I must stare for 30 seconds at console.
0
Comment
Question by:Nusrat Nuriyev
  • 5
  • 2
7 Comments
 
LVL 25

Assisted Solution

by:Zephyr ICT
Zephyr ICT earned 500 total points
ID: 40614543
It could be several things client or server, you'll need to check both..

What happens sometimes is that reverse DNS is not working like it should, you could try by turning DNS requirement off in the ssh config file by adding "UseDNS no" to /etc/ssh/sshd_config

Another thing that sometimes solves these issues is by turning off GSSAPI authentication by adding the line "GSSAPIAuthentication no" to /etc/ssh/ssh_config or maybe on the client side, then it will go into  ~/.ssh/config probably.
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40616732
well, there is no delay before password prompt on other MAC client, I have noticed.
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40616746
GSSAPIAuthentication no on server side helped for eliminate delay BEFORE prompt.
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 

Author Comment

by:Nusrat Nuriyev
ID: 40616756
Also, calling command
ssh hostname.domain -l root -p 9333

Open in new window

helped with eliminating delay BEFORE password prompt.
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40616767
connection closed by XXX.XXX.XXX.XXX
AFTER password prompt still persists. How to increase wait time after password prompt?
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40616779
callling
ssh hostname.domain -l root -p XXXX

Open in new window

has not helped in eliminating delay BEFORE. Unconfirmed.
0
 
LVL 25

Accepted Solution

by:
Zephyr ICT earned 500 total points
ID: 40617567
You could try setting the "LoginGraceTime" to 0 (zero) in the ssh config file on the server, or to a more specific number of minutes, like you want ...
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question