how do i increase the timeout on a report?

How can i increase the timeout on reports?
vbnetcoderAsked:
Who is Participating?
 
sammySeltzerConnect With a Mentor Commented:
Please follow these steps to increase timeout reports:

1) Set the HttpRuntime ExecutionTimeout value to a greater value (ie 3 hours) on the Report Server

 How do you do this? Simple!

 a.       Open the ReportServer’s Web.config file by going to Start -> Administrative Tools -> Internet Information Services.
 b.      From there, expand Web Sites -> Default Web Site, and click on ReportServer. On the right-hand pane, right-click ‘Web.Config’ and select ‘Open’.
c.       Locate the HttpRuntime parameter. If it doesn’t exist, you will have to create it within the <System.Web> section.
 d.      Set the executionTimeout value to ‘10800’ (3 hours) as shown below:


<system.web>
 <httpRuntime executionTimeout = "10800" />
 </system.web>


2) Increase the script timeout on the report server

    1. Go onto your Reporting Server and open up Internet Information Services; right-click on the ReportServer and select Properties.
    2. Go to the Options tab, and set the ASP Script timeout to 300 seconds as shown below.

3) Set the report to never time out on the server

    1. Open your web browser on the server and go to http://localhost/Reports
    2. Navigate to the Report location and click on the problem report(s).
    3. On the left-hand pane, click on Properties.
    4. In the ‘Report Execution Timeout’ click the ‘Do not timeout report execution’.

Credit: http://geekswithblogs.net/ssrs/archive/2009/10/30/steps-to-resolve-ssrs-timeout-issues.aspx
0
 
Alpesh PatelAssistant ConsultantCommented:
Report Process
Select appropriate option as highlighted.
0
 
vbnetcoderAuthor Commented:
ty
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.