Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Zebra GK420d labelwriter not working on our main subnet

Posted on 2015-02-17
5
Medium Priority
?
681 Views
Last Modified: 2015-02-18
We had a Zebra GK420d connected to our network for about a year and a half before it suddently went offline. I tried pinging the printer but without luck. Pinging it continiusouly I realized it actually made a reply 1-2 SOMEtimes when rebooting the printer/moving the cable to a different port on the switch, but quickly going offline again. I've trive multiple network cables and connection it to different switches on our main network.

I bought a new identical printer only to realize it had the exact same issues, so I tried moving it to another subnet and it worked completely fine! I tried connecting it to my home network and it works fine there as well!

I explained my problems to ZebraCare but was told they didn't ever have any similar problems, and since the problem is network related they cannot help me.

How can I make sure the printer isn't using a different IP-address right after responding to the one I assigned it? Can I hunt it down by it's macaddr somehow?

Any tips on how to proceed debugging this?
0
Comment
Question by:Erlend Ausland
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 12

Expert Comment

by:Bryant Schaper
ID: 40615002
Sure, is it assigned by DHCP?  You can use ARP to find the IP/MAC.  Also could it be shutting down becuase of a duplicate IP address.

What kind of switches and routers do you have?

Or download a free IP address scanner to discover everything on network.
0
 

Author Comment

by:Erlend Ausland
ID: 40615026
I can see the designated IP-address assigned in the DHCP-server, and when pinging continuously it actually does respond a couple of times (sometimes!) before "disappearing" again.

Switches are HP, routers are Cisco.

The printer is currently hooked up on a J9079A small HP switch in my office. I also have it connected through USB and tried setting a static IP through the softwares interface, however I haven't actually been able to verify wheter this setting is actually applied (based on the original problem with the printer being it isn't online when it "should" be!).

I have tried using a program called "Managed Switch Port Mapping Tool 2.42" and pointing it to the IP-address of my J9079A-switch, it indicates port 7 (which is the one the printer is currently connected to) is online, but it doesn't provide me with any more information. The other ports shows MAC etc. for connected devices, but port 7 is blank (other than registered as online..).
0
 
LVL 12

Accepted Solution

by:
Bryant Schaper earned 1500 total points
ID: 40615047
does it support USB and ip at the same time?

On the cisco router you can run show arp and look for the mac, or show arp | in xxxx where xxxx is the last 4 of the mac no colon.

 on the hp you can use show mac-address and look for the mac on the port.

Do you have any additional entries in DHCP it may pickup after?
0
 

Author Comment

by:Erlend Ausland
ID: 40615082
Your comment on wheter it supports both USB and IP on the same time or not got me thinking a little bit, and simply sending the config for DHCP/static IP to the printer doesn't actually append them (as in having the printer reboot or something like that).

So i cleaned DHCP-records for the printer, used my Zebra-tool connected via USB to set it to DHCP and then sent a "Reset printer"-command using the same Zebra-tool. This registered the printer in the DHCP, but I could not ping it.

So I statically assigned the IP address using the Zebra-tool and sent a "Reset printer"-command, THIS TIME IT ACTUALLY SEEM TO WORK!

I have now been able to ping my printer for a few minutes, but I am at home remotely working do my desktop PC so I will have to do check it on location tomorrow. This seems to probably have solved my problem, however I am still puzzled about why the DHCP function for this particular printer (different physical printers, different firmwares) troubles with DHCP.
0
 
LVL 12

Expert Comment

by:Bryant Schaper
ID: 40615105
I have seen some devices send different MAC addresses than the printed address.  Cannot say why that one is having a problem.  Does it have a firmware update.  Would probably not install if it fixes it, but could just be a bug
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question