Solved

Quickbooks Database Server Manager services crashes when file is opened

Posted on 2015-02-18
15
4,299 Views
Last Modified: 2015-12-30
Over the weekend, we applied the updates on our 2008 R2 Standard server. This server is a virtualized machine. We use this machine to run our QuickBooks Database Manager software and store the quickbooks file.

After rebooting server, we can no longer open any of our QB files. All services come up normally. However, if any client workstations opens any QB file, the QuickbooksDB23 service immediately stops and the client starts receiving a variety H202 errors or (-6000, -301). This makes sense since that this point, the Database manager service is no longer running.

I contacted support who completely uninstalled the server manager from the server, ran their "clean up" tool, reinstalled the entire application including the front end and tested again with the same error and result. We even tried to open the file from the server directly and it didn't work. It doesn't matter if you try to open the file in single user or multi user mode. The application does allow you to put in credential for the QB file so it doesn't immediately crash the service until after you try to authenticate. (I am logging in as admin in the file).

Their resolution was that QB is not support on a VM because it's too unstable. The work around was to copy it to a local workstation and open it in multi user mode there. For whatever reason, that worked and they want QB to be on physical server not a virtualized one. This install of QuickBooks has been installed on this server for at least 2.5 years and has been on several versions of Enterprise without issue.

My guess was that it was due to a MS update that came down. I uninstalled each patch that was applied (and for the most part had to restart the server in between each patch), tried it again in between each patch removeal and it still didn't work. All of .NET 4.5 is off of the server. I've attach a list of patches that I removed from the weekend update.

The following error keeps getting logged each time someone tries to open the file. I have researched this thing to death and I can't seem to find anything regarding this issue. What support told me is that the QB service is trying to make a registry entry each time someone opens the file and is getting denied (which didn't make sense to me). However, I dropped the local Quickbooks account it creates in order to run the QuickbooksDB23 service in to the local administrator group on the server and tried it again but it's still the same error.

Right now the file is still loaded on a workstation. I was wondering if anyone can help me with this error. I have no idea what SQLANY has to do with QB or how to correct this.

Thank you.
Log Name:      Application
Source:        SQLANY 11.0
Date:          2/16/2015 6:21:22 PM
Event ID:      1
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      JBCSVR01.jbc.local
Description:
The description for Event ID 1 from source SQLANY 11.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

QuickBooksDB23
*** ERROR *** Assertion failed: 100904[1bb5ff83bcf04b159c01cba79ee6f579] (11.0.1.2584)
Failed to redo a database operation (id=4, page_no=0x575f5, offset=0x7dc) - Error: Cannot access file 'C:\Users\

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SQLANY 11.0" />
    <EventID Qualifiers="0">1</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-02-17T01:21:22.000000000Z" />
    <EventRecordID>23033</EventRecordID>
    <Channel>Application</Channel>
    <Computer>JBCSVR01.jbc.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>QuickBooksDB23</Data>
    <Data>*** ERROR *** Assertion failed: 100904[1bb5ff83bcf04b159c01cba79ee6f579] (11.0.1.2584)
Failed to redo a database operation (id=4, page_no=0x575f5, offset=0x7dc) - Error: Cannot access file 'C:\Users\</Data>
  </EventData>
</Event>
Updates.txt
0
Comment
Question by:paynster
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
15 Comments
 
LVL 95

Expert Comment

by:John Hurst
ID: 40616572
So the workaround shows the database is probably OK and that the QB installation on Workstations is also OK.

With respect to the error and the use of database and server manager on a virtual machine:

It should work on a VM. I have done that for years at one client.

At another client with the database and server manager on a real machine, I got the same / similar error.

The resolution above was to adjust the firewall settings. You can download the Network Troubleshooter from Intuit and run it and then see if your firewall is blocking access.

Please let us know.
0
 

Author Comment

by:paynster
ID: 40617192
Do you have the link to that by chance. I'll google it and see if I can find it.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 40617467
Here is the Intuit link for the troubleshooter.

http://support.quickbooks.intuit.com/support/networking/

Please let us know if you make some progress.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:paynster
ID: 40618614
Thank you. When I try to run this, the option to fix Network connectivity is greyed out. It wants me to pick a file and then it will look at both. See attachment. I will pick one of our files and try it to see what happens.  I also doubled checked the firewall settings like you suggested. The firewall on the server isn't turned on. See attachment.

I'll run the tool and post what it finds.
FileDoctorOptions.JPG
Firewall.JPG
0
 

Author Comment

by:paynster
ID: 40618625
So it finished and it said "your file can't be repaired". The file has been used for three days by on another machine so I don't think this error is correct. I ran this on the server (the hosting machine). Did I need to run this on a workstation for the network connectivity option to show up?
FileDoctorMessage.JPG
0
 

Author Comment

by:paynster
ID: 40618655
Same error if I run this from a workstation.
0
 
LVL 95

Accepted Solution

by:
John Hurst earned 500 total points
ID: 40618707
There are a lot of messages here.

Try the following:

1. Put the company file on a local machine. Copy both the QBW and TLG files to a local machine. Open the company file locally. Make sure there is the original copy and then try to rebuild the Company file. In QuickBooks, File, Utilities, Rebuild Data. Rebuild MUST be done on a local machine.

Does the Rebuild work?

2. On the Server, uninstall the Server Manager (and QB if you happened to have installed it there). Now run System File Checker. Open cmd.exe with Run as Administrator. Run SFC /SCANNOW and allow to complete. Close out and now you should Restart the server. You may need to wait for a quiet moment. After restart, install just the Server Manager. Install it on the same partition on the server where the company QBW file is located.

Does the Server Manager work?
0
 

Author Comment

by:paynster
ID: 40618730
Hi,

We did put the company file on a local machine already. That's how the users are currently able to work. The only work around support could come up with was to move it to a workstation (again, they wanted it on a physical machine versus virtualized) and have the workstation host it from there.

When we moved it off the server, we never had to do a repair on it. We just moved the qbw file and had the workstation host it out to the users. It worked with out issue. Do you want me to move that copy and the associated files back to the server to see if it can open it?
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 40618740
Before you move it back, it is good housekeeping to do a rebuild. Once done (successfully let us assume) keep a copy locally and then copy it back to the server and see (after the steps to fix Server Manager) if you can open it.
0
 

Author Comment

by:paynster
ID: 40619045
Ok sounds good. I will have to do this after hours since the users are now in the file but I'll update this later tonight and let you know. Thank you.
0
 

Author Comment

by:paynster
ID: 40625498
Ok so I took  the local copy of the file, backed it up with the data verify on and did the rebuild. I then copied just the .qbw file back out to the server but put it in a new location. I updated the database manager with the location and issued a scan. I then opened QB on the local server in multi user mode and it seems to work. No idea why.

I'm re-apply the updates I removed, I'll reboot the server and try it again. If it works, I'll try to open it from another workstation so that more then one person is in it. I'll keep you posted. Thanks.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 40625534
did the rebuild. ..... server in multi user mode and it seems to work  <-- Doing a rebuild is a good thing to do when a database is giving issues.

Make sure QuickBooks is up to date, reapply any updates you removed, and please let us know after you reboot the server.
0
 

Author Comment

by:paynster
ID: 40630387
Here's what I did. I took the old QuickBooks folder where the file was stored on the server, broke the share and renamed it. The then recreated the folder, created the share and moved the file out to that location. I did a scan with the database manager. All seemed ok.

I then logged onto the client and tried to open it. I received an error so I remapped the drive, rebooted the client workstation and it opened in multi user mode. So did the rest of the clients. So it seems we're ok now. I'm not exactly sure what fixed it. I have a feeling moving off of the server did the trick for some reason and opening it on a local client.

In any event, we are back up and running. Thanks for your help!!
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 40630445
@paynster  - Thanks for the update and I was happy to help you.
0
 
LVL 9

Expert Comment

by:tsaico
ID: 41390751
Also a little late to the game, but I had found the service was not running on our server.  I switched the service to run under "local account" instead of teh QB user and the service would start up as normal.
1

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Quickbooks 2016 Premier PDF Converter not working 1 53
Change Exchange 2010 Namespace 6 71
FTP servers in Windows 2008 5 96
RDP authentication error 3 69
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question