Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Unable to start NMONVisualizer...problem with java. what am I doing wrong?

Posted on 2015-02-18
12
Medium Priority
?
631 Views
Last Modified: 2015-03-09
Hello all,

This ismy first time using NMONVisualizerr and I am experiencing the following error. What am I doing wron? What do I need to do to get NMONVisualizer working? Any and all assistance will be highly appreciated. The error I am getting follows:

rapmq02hdqra /home/rapmq01i/workdir/perfmon/JarFile >java -jar NMONVisualizer_2015-02-02.jar


Exception in thread "main" java.lang.NoSuchMethodError: java.net.URLDecoder: method decode(Ljava/lang/String;Ljava/lang/String;)Ljava/lang/String; not found
        at org.eclipse.jdt.internal.jarinjarloader.RsrcURLConnection.getInputStream(RsrcURLConnection.java:42)
        at java.net.URL.openStream(URL.java:827)
        at sun.misc.URLClassPath$Loader.getResource(URLClassPath.java:449)
        at sun.misc.URLClassPath.getResource(URLClassPath.java:166)
        at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:676)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:239)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:516)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:448)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:220)
        at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:54)

 

Thanks for your assistance.


Enyimba
0
Comment
Question by:Enyimba
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 14

Assisted Solution

by:Mark Bullock
Mark Bullock earned 500 total points
ID: 40616960
It's possible you are using an older version of java.
Run the command java -version.
If it's prior to 1.8, consider upgrading.
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 40616970
This looks quite as if your Java version were too old (1.3?)

If your OS is indeed AIX 7.1 then you should be fine with Java 5 which comes with that version, however.

What do you see with "java -version" and "oslevel -r"?
0
 

Author Comment

by:Enyimba
ID: 40617094
Guys, this what I am getting:

java version "1.3.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1)
Classic VM (build 1.3.1, J2RE 1.3.1 IBM AIX build ca131-20051025 (SR9) (JIT enabled: jitc))
rapmq02hdqra /home/rapmq01i/workdir >


oslevel -r
7100-03

It looks like I will need to talk to some "grumpy" AIX folks in my shop, would you agree? Also, can I run NMONVisualizer in windows? If so, I could just as well run topas_nmon on AIX, ftp the data to my windows environment and work from there if my AIX people are not in a hurry to upgrade java. Is that workable? please respond...

Thanks

Enyimba
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 68

Assisted Solution

by:woolmilkporc
woolmilkporc earned 1500 total points
ID: 40617109
With AIX 7.1 you should have newer versions of Java available.

Please check

ls -d /usr/java*

If you see directories looking like "java5" or "java5_64" or "java6" or "java6_64"

then you can retry with (example)

/usr/java6/bin/java -jar NMONVisualizer_2015-02-02.jar

You can also try the 64bit versions, if present.

Consider changing your PATH to contain e.g. "/usr/java6/bin:/usr/java6/jre/bin" instead of the current value which is probably "/usr/java13/bin:/usr/java13/jre/bin"
0
 

Author Comment

by:Enyimba
ID: 40617294
woolmilkporc,

I have just searced and found java5 and java6. I followed your recommendation and ran into the following error. Do you know what my problem may be? Thanks

rapmq02hdqra /home/rapmq01i/workdir/perfmon/JarFile >/usr/java6/bin/java -jar NMONVisualizer_2015-02-02.jar

Feb 18, 2015 2:07:47 PM java.util.prefs.FileSystemPreferences$2 run
INFO: Created user preferences directory.
java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
        at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:174)
        at java.awt.Window.<init>(Window.java:443)
        at java.awt.Frame.<init>(Frame.java:414)
        at javax.swing.JFrame.<init>(JFrame.java:213)
        at com.ibm.nmon.gui.main.NMONVisualizerGui.<init>(NMONVisualizerGui.java:108)
        at com.ibm.nmon.gui.main.NMONVisualizerGui$1.run(NMONVisualizerGui.java:45)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:220)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:690)
        at java.awt.EventQueue.access$400(EventQueue.java:92)
        at java.awt.EventQueue$2.run(EventQueue.java:651)
        at java.awt.EventQueue$2.run(EventQueue.java:649)
        at java.security.AccessController.doPrivileged(AccessController.java:298)
        at com.ibm.oti.security.CheckedAccessControlContext.securityCheck(CheckedAccessControlContext.java:30)
        at sun.misc.JavaSecurityAccessWrapper.doIntersectionPrivilege(JavaSecurityAccessWrapper.java:41)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:660)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:280)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:195)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:185)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:180)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:172)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:133)
rapmq02hdqra /home/rapmq01i/workdir/perfmon/JarFile >
0
 

Author Comment

by:Enyimba
ID: 40617310
woolmilkporc,
I ran the process again, this time I supplied the input file as shown. I tried it with java6 and with java5. Both return with error as shown:

rapmq02hdqra /home/rapmq01i/workdir/perfmon/JarFile >/usr/java6/bin/java -jar NMONVisualizer_2015-02-02.jar rapmq02hdqra_150218_1331.nmon

Exception in thread "main" java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
        at java.lang.reflect.Method.invoke(Method.java:611)
        at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:56)
Caused by: java.lang.ClassNotFoundException: rapmq02hdqra_150218_1331.nmon
        at java.lang.Class.forName(Class.java:182)
        at com.ibm.nmon.DelegatingMain.main(DelegatingMain.java:19)
        ... 5 more

rapmq02hdqra /home/rapmq01i/workdir/perfmon/JarFile >/usr/java5/bin/java -jar NMONVisualizer_2015-02-02.jar rapmq02hdqra_150218_1331.nmon

Exception in thread "main" java.lang.UnsupportedClassVersionError: (com/ibm/nmon/DelegatingMain) bad major version at offset=6
        at java.lang.ClassLoader.defineClassImpl(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:267)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:151)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:602)
        at java.net.URLClassLoader.access$400(URLClassLoader.java:126)
        at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1057)
        at java.security.AccessController.doPrivileged(AccessController.java:361)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:494)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:651)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:617)
        at java.lang.Class.forNameImpl(Native Method)
        at java.lang.Class.forName(Class.java:204)
        at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:54)
rapmq02hdqra /home/rapmq01i/workdir/perfmon/JarFile >

Any other things to try?

Thanks
0
 
LVL 68

Assisted Solution

by:woolmilkporc
woolmilkporc earned 1500 total points
ID: 40617331
The first error is due to missing X11 support. You need an X11 server on the client side.
From Windows best use MobaXterm (Home Edition): http://mobaxterm.mobatek.net/download.html

As for the second error: Please try the Java 64bit version, if present.
0
 

Author Comment

by:Enyimba
ID: 40617350
I don't see java 64bit in my list. Could you explain what you mean by "From Windows best use MobaXterm (Home Edition): http://mobaxterm.mobatek.net/download.html"?
0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 1500 total points
ID: 40617383
MobaXterm is a self-contained executable for Windows
which provides ssh access to hosts just like PuTTY does, but which is also an X11 server that is needed to display on Windows NMONVisualizer's graphics coming from AIX.

The 64bit versions are in /usr/java5_64" and "/usr/java6_64".

Did you try Java6 (64bit or not)?

If anything fails you could indeed transfer the nmon file(s) to Windows and try to run the visualizer there.
If using FTP for the transfer take care to specify "binary" transfer mode!
0
 

Author Comment

by:Enyimba
ID: 40617444
woolmilkporc,

Please disregard the last question...I download from mobaXterm, installed it and it was easy to follow what it was doing...now let me see if this solves my problem(s)
0
 

Author Comment

by:Enyimba
ID: 40617617
woolmilkporc,
Nope...I still have the problem...here's what I get when I try to run the jar file from mobaXterm. Note: I logged in to the AIX server from mobaXter and tried to run the jar file that way and when I did, nothing happened. Frankly, I will prefer to run from windows environment. So I will focus on getting this baby working in that environment...

If I run from the windows environment, do I still need Xterm? I I thought that's what windows do natively, right?

I will try to run on windows and report back....
0
 

Author Closing Comment

by:Enyimba
ID: 40655382
Thanks guys
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post we will learn different types of Android Layout and some basics of an Android App.
This article discusses how to create an extensible mechanism for linked drop downs.
Viewers will learn one way to get user input in Java. Introduce the Scanner object: Declare the variable that stores the user input: An example prompting the user for input: Methods you need to invoke in order to properly get  user input:
This tutorial covers a practical example of lazy loading technique and early loading technique in a Singleton Design Pattern.
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question