Solved

Windows 8 will not allow installation, many features disabled.

Posted on 2015-02-18
5
110 Views
Last Modified: 2015-02-23
In Win8.1 64-bit, Unable to install software, unable to restore, unable to open event viewer. Windows update won't show installed updates nor will it find new ones to install.

In short, it appears that .NET framework was broken, the Visual C++ 2005 group of files were also uninstalled from the add/remove program. The best error message I have is:
An error occurred during the installation of assembly 'Microsoft.VC80.CRT.type="win32",version=8.0.50727.6195".publicKeyToken=
"1fc8b3b9a1e18e3b".processorArchitecture="amd64". Please refer to help and support for more information HRESULT: 0x800700C1.

(This particular error was created by trying to install a freshly downloaded copy of iTunes, but it has also appeared with different variations when I try to install many programs.)

Hitman and McAfee show no virus. Very lightly used, newish all in one HP PC, so I do not suspect virus. I think it's the software. Where do I go next?
0
Comment
Question by:Elixir2
  • 3
5 Comments
 
LVL 1

Author Comment

by:Elixir2
ID: 40618183
Type Notepad on start screen, and press enter.
Copy the following text, and then paste the text into Notepad.
net stop wuauserv
cd %systemroot%\SoftwareDistribution
ren Download Download.old
net start wuauserv
net stop bits
net start bits
net stop cryptsvc
cd %systemroot%\system32
ren catroot2 catroot2old
net start cryptsvc

[from here]
I tried this and windows updates just scans and scans, nothing ever happens.
0
 
LVL 1

Author Comment

by:Elixir2
ID: 40618186
Also tried this:
DISM.exe /Online /Cleanup-image /Restorehealth
I get error 193
%1 is not a valid win32 application.
0
 
LVL 19

Assisted Solution

by:*** Hopeleonie ***
*** Hopeleonie *** earned 250 total points
ID: 40618222
Run also the System File Checker tool (SFC)
http://support.microsoft.com/kb/929833
0
 
LVL 30

Accepted Solution

by:
flubbster earned 250 total points
ID: 40618759
When you said unable to restore, am not sure if you mean a system restore or full refresh/reset.

have you tried this:

Boot the system, then while holding the shift key, select to restart the computer. Continue holding the shift key until you get to the troubleshooting screen. There you will have options to refresh or reset the system. If it feasible for you, select to do a full reset. This will re-install from the recovery partition.

BTW... if you would like to enable some more troubleshooting options via the good old F8 safe mode menu, do the following:

Press the windows key + x. This will open the Power Users Tasks Menu. Select Command Prompt (Admin).

At the C:\windows\system32> prompt, type the following and hit <enter>

bcdedit /set {default} bootmenupolicy legacy

Restart for the change to take affect. Now, pressing F8 at boot will open the Safe Boot Menu just like in previous OS's.
0
 
LVL 1

Author Closing Comment

by:Elixir2
ID: 40626380
In this case, it was a very strange situation. All of the command you mentioned would not work, with each some kind of cryptic error. The first time I tried to do a system restore, it took forever to come back and tell me the service failed/could not find restore points, etc. So I pulled the machine and took it back to my shop.

After trying an hour or so of other stuff, I gave up and tried to do a system restore again. This time it worked and showed me restore points at the beginning of the month. I ran with one of those, and after about 4 hours, the machine said it successfully restored. I restarted and verified that it indeed had restored ... almost fixed. All of the .NET framework and MSXML entries were back in place.

But... I tried to view the Add/Remove Programs area and that worked, but still under the section where you add/remove Features from Windows, that list came up blank again, like Windows had no features installed. And Windows Update still would not work, just sat searching for hours. AND of course, the final straw, iTunes still gave the same error as in the OP.

Next step was to do a factory restore, and perhaps because I had already done a system restore (roll back), this time factory restore worked. And after about 4-6 more hours, the machine came back to a ready out-of-the-box state.

About 12 more hours of copying user files back into place, downloading (yes, I have HSIA 10M up and down) and installing software and then running updates and letting them install and then restarting and repeating the same process about three times until no further updates were available... and voila, we have a nice shiny new Win8.1 64 bit all in one.

BUT WHY!?!??  WHY IN THE &#(S?! WOULD ANYONE WANT TO DO THIS AFTER ME? *#*% WIN8. THIS IS TOTAL &*@#*(@)(#*!!!!!

(I seriously considered as you should too at this point to put win7 backward on any machine you find win8 on...LOL! JUST MY HUMBLE OPINION!)
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
The goal of this Micro Tutorial is to help navigate beginning users with the app store on Windows 8. It will explain exciting features how to maximize your PC through these apps. This will be demonstrated using Windows 8 operating system.

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question