Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 46
  • Last Modified:

Transition from Exchange 2010 STD to 2 Exchange 2013 STD Servers. Any Tips.

I'm in the process of upgrading from Exchange 2010 to 2 Exchange 2013 servers. I've created my mailboxes and Database availability group on the new servers and all statues are healthy. I've imported my wildcard certificate from my old server to the both 2013 servers and enabled IIS and SMTP to use this certificate. I've created a couple of test accounts to test mail flow, and mail flow is working between all three servers. One thing I'm having an issue with is connectivity with Outlook clients (2010 and 2013). I receive certificate errors and proxy server errors. It is my understanding that Microsoft is now using only "Outlook Anywhere" for all connectivity between the server and the client with Exchange version 2013. I checked the exchange proxy settings on one of the Outlook clients and noticed the MSSTD setting is not configured properly. Its supposed to have the wildcard certificate in the MSSTD field but instead it has mail.domain.com. After doing some research, there's a command that you use in exchange power shell to make changes to the OUTLOOK PROVIDER. But I'm afraid this will affect the old exchange server as well. I'm trying to make this a smooth transition, and avoid creating problems for users. Does anyone have recommended steps on how to proceed from this point?

Thank you for your time.
0
Domenic DiPasquale
Asked:
Domenic DiPasquale
  • 2
1 Solution
 
Simon Butler (Sembee)ConsultantCommented:
If you were using a wildcard certificate before, then setting must have already been set.
It is a global setting which you can see thus:

get-outlookprovider

With a wildcard certificate it will have to say *.example.com for the first two entries.
If you are mixing certificate types, then you will have to either put the wildcard certificate on the old platform or change the new server to have a specific URL certificate instead of a wildcard.

Simon.
0
 
Domenic DiPasqualeSystem / Network AdministratorAuthor Commented:
These are the results when I run GET-OUTLOOKPROVIDER:
Name                          Server                        CertPrincipalName             TTL
----                                  ------                                -----------------                      ---
EXCH                                                                                                                  1
EXPR                                                        msstd:*.domainhidden.com         1
WEB                                                                                                                   1
I checked one of the test mailboxes on one of the exchange 2013 servers, and I noticed that the MSSTD setting is using mail.domainhidden.com. I'm also getting certificate warnings: "The name on the security certificate is invalid or does not match the name of the site." It's trying to match the exchange servers internal hostname with the wildcard. I don't understand why I'm not receiving any issues on my exchange 2010 server.
0
 
Simon Butler (Sembee)ConsultantCommented:
Outlook does not use Outlook Anywhere to connect to the Exchange 2010 server, so certificate warnings will not occur. The only time you would get certificate warnings is for Autodiscover.

You can see the internal Autodiscover settings thus:

get-clientaccessserver | select identity, autodiscoverserviceinternaluri

The host name on the result should be covered by the certificate.

Simon.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now