Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Pretty permalinks on wordpress

Posted on 2015-02-19
13
Medium Priority
?
141 Views
Last Modified: 2015-02-21
I want to name pages on  wordpress with some meaningfull names.
For example, this page link
http://www.domain.com/?p=11
desired to be
http://www.domain.com/main

How it's stored in the internal, its own problem. The key point is fast navigation for user by address line.
This thing is absolutely important, however, WordPress kinda lives in parallel universe.
How to solve the problem?

Wordpress 4.1.1
Fedora 20
Apache/2.4.10
0
Comment
Question by:Nusrat Nuriyev
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 2
  • +1
13 Comments
 
LVL 2

Assisted Solution

by:axessJosh
axessJosh earned 400 total points
ID: 40620340
Did you go to settings >> permalinks?

From there you choose postname or type custom %postname%

Is that what you're wanting?
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40620348
that does not work.

it gives "404 file not found" when i chose postname permalink. Only defauly ones work.

Why?
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40620382
ok, kinda solved the problem by adding changing custom to
/index.php/%postname%

Open in new window

Why I need to add that index.php?
0
Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

 
LVL 2

Expert Comment

by:axessJosh
ID: 40620386
what domain URI do you have setup in Settings >> General
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40620414
Web-site url: http://i-olimp.com

The problem that I have eliminated usage of index.php prefix before custom permalink on other site, but not this one.
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40620426
second time, the problem was in path of Directory tag of httpd.conf
0
 
LVL 18

Assisted Solution

by:Lucas Bishop
Lucas Bishop earned 1600 total points
ID: 40620581
Did you figure this out? You'll want to enable permalinks as axessJosh mentioned.

 If you receive a 404 error, then there are a few things to look at:

1.) Is your .htaccess file writable (666 permission)
2.) If your .htaccess is writable, does it allow symlinks at the top? It should:
Options +FollowSymlinks

Open in new window

3.) If .htaccess is writable, and has followsymlinks enabled, then you'll want to make sure that apache vhosts allows .htaccess to override the server settings:

<Directory "/path/to/website">
  Options FollowSymLinks
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>

Open in new window

0
 
LVL 8

Expert Comment

by:Alicia St Rose
ID: 40621212
Sometimes just hitting save again on the Edit Permalinks page in the admin does the trick. It refreshes everything.
0
 
LVL 2

Expert Comment

by:axessJosh
ID: 40621344
I agree with laughhearty,

Sometimes WP just gets finicky and you have to do the exact same thing twice.
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40623021
Lucas, in your scenario we don't need to modify .htaccess?

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
~                   

Open in new window

0
 

Author Comment

by:Nusrat Nuriyev
ID: 40623023
Lucas,
1.) Is your .htaccess file writable (666 permission)
Isn't that dangesours to make writable for other users?

axessJosh
laughhearty
That was not an issue.
The issue was on apache configuration file.
Everytime(for every web-site) I have to mention "index.php".
I don't know how to make it by default for all web-sites.
0
 
LVL 18

Accepted Solution

by:
Lucas Bishop earned 1600 total points
ID: 40623255
Nusrat, when you edit the permalink layout in the WP admin area, if the .htaccess file is not writable, then you'll see a message at the bottom with the rewrite structure that needs to go in the htaccess file. You'll have two options:

1.) Make htaccess writable 666. Update the permalink structure in WPadmin. Change htaccess permissions back to 644 (for security)

2.) Copy the rewrite rule specified in the WP Admin into the htaccess file manually, without changing any permissions
0
 

Author Comment

by:Nusrat Nuriyev
ID: 40623671
okay.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Like there are many different versions of Wordpress, there are also a handful of related side projects WordPress users should be familiar with.   All of these projects are open source and GPL licensed, which means there are few restrictions to us…
Transferring a wordpress site from a host or local dev server to another host can be a pain. So I've included my steps on how I have accomplished this task. Steps include an assumption that you have Cpanel access or Ftp access.. If you do not hav…
The purpose of this video is to demonstrate how to create a Printer Friendly PDF on a WordPress Page. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome Screenshot” Google Chrome Extension, and SmallPDF.com Log…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…
Suggested Courses

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question