Solved

How can I allow NAT Loopback on a Draytek Vigor 2820

Posted on 2015-02-20
4
1,179 Views
Last Modified: 2015-03-04
How can I allow NAT Loopback on a Draytek Vigor 2820?

We are setting up soft phones from mobile devices and they can only be set to use the external IP, problem is you can't access the external IP from inside the network. So I think I need to allow NAT Loopback, problem is I'm not sure how to achieve this, I have taken a pretty good look on the internet?

Any help would be great! Thank you
0
Comment
Question by:corecc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 37

Expert Comment

by:bbao
ID: 40622583
> problem is you can't access the external IP from inside the network.

why don't you access its internal address directly? any difference?
0
 
LVL 9

Assisted Solution

by:Rob_Jeffrey
Rob_Jeffrey earned 250 total points
ID: 40622613
What is the firmware of your Draytek?  The 3.3.4.1 and 3.3.5.1 may not work.
http://durdle.com/archives/2011/01/05/nat-loopback-broken-on-draytek-vigor-2820-firmware-3-3-3/

Check for an updated firmware.

Hope this helps.
0
 
LVL 27

Accepted Solution

by:
Steve earned 250 total points
ID: 40623035
nat loopback is available but was only listed as a supported feature in recent firmwares. Previously it often worked but wasn't guaranteed to.
Update your firmware and give it a go. if it doesn't work on the most recent firmware you'll have to update to a newer router, as the 2820 is end of life now.
0
 
LVL 1

Author Closing Comment

by:corecc
ID: 40644152
My apologies for the delayed reply, I eventually spoke directly to Draytek support and unfortunately they were not a great deal of help. The conclusion is that NAT loop back is a feature of particular routers and is no something that can be turned on or off. If the router has this feature then it is just on. The Draytek 2820 does support this feature in more recent versions of the firmware, however as we are currently on the most recent version of the firmware it would suggest that this has nothing to do with NAT loop back not working. This was also Drayteks opinion and as such they were going to look into other reasons why this isn't working.... although I still haven't heard anything.

The reason for wanting NAT loop back to work was so portable softphones (iphone) set up to see the external IP only would work inside the office as well as outside. As they point to the external IP and you can't access the external IP inside the office the phones didn't work. So the answer was to point the phones to a domain name instead, e.g. pbx.companyname.com then create a DNS record on the name servers which points to the external IP.  Inside the office I created the same DNS record (pbx.companyname.com) on the DNS server to point to the internal IP address of the phone system (PBX). Now the phone works inside and outside the office!

Thanks for everyone's help.
0

Featured Post

Now Available: Firebox Cloud for AWS and FireboxV

Firebox Cloud brings the protection of WatchGuard’s leading Firebox UTM appliances to public cloud environments. It enables organizations to extend their security perimeter to protect business-critical assets in Amazon Web Services (AWS).

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Web site adult filtering solutions for a small LAN network 27 189
replacing 2811 to ISR 4331 2 44
ASA5510 Blocking a Wanted Website/Host 9 46
Factory Reset of Juniper SSG20 2 42
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question