Solved

Cisco 7945G phones dead after switch reboot

Posted on 2015-02-20
12
367 Views
Last Modified: 2015-02-24
After power was cut to one of my switches (thanks building maintenance) three phones would not boot. They start to boot but then only speaker light comes on and then nothing else. I tried using a power supply instead of PoE thinking perhaps the PoE negotiation got pooched. But no luck. I also tried holding down the # key during boot to get the phone to factory reset. But this also did not work. Does anyone know of some other knob I could try to turn to recover these phones before I send them off to e-waste??
0
Comment
Question by:amigan_99
  • 7
  • 4
12 Comments
 
LVL 9

Expert Comment

by:Rob_Jeffrey
ID: 40622578
It may be possible that a bus is pooched on one of the switches.  Are all affected phones on the same switch?  Can you swap positions with a working phone to see if the problem goes with the port it is plugged into or if the phone itself has an issue?
0
 
LVL 1

Author Comment

by:amigan_99
ID: 40622584
Yes - I took each of the three bad phones and patched them to the cable of my own working 7945G. Then I thought - well perhaps the switch is out of power to give so I tried using a power supply. But alas the same result.
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 40623103
I think they lost their firmware somehow and now they are trying to obtain DHCP settings to be able to reprovision the firmware and configuration files.

These phones are really hard to brick. When they behave this way it is most likely because the DHCP discovery is not working, but we can break it out into 2 problems:

DHCP is working and the phone is getting IP, subnet and gateway, but no TFTP option to go look for the firmware files

DHCP discover messages come out of the phone but cant reach the DHCP server, or the DHCP server replies back and never reaches the phone

What type of switch do you have? Can you configure a small DHCP pool in it?
0
 
LVL 1

Author Comment

by:amigan_99
ID: 40623312
The subnet for the voice vlan has DHCP served by a Windows domain controller which also runs DHCP. Normally if a phone can't find the DHCP server it will at least boot up even though it's not functional. But you raise a good thought. When I'm back in the office I will check the byte counters on the port and see if they increment and if they do I can could span a port and see what's happening at the DHCP level if anything.
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 40623598
Yes, a packet capture will do magic for us.

And yes, the phones do not act like this unless their firmware is erased from flash, which happens if during an upgrade or downgrade they loose connectivity before completing the process.
0
 
LVL 1

Author Comment

by:amigan_99
ID: 40623624
That's an interesting point. It's possible that I specified an upgrade in firmware but never got around to booting these three. Then during this event perhaps power went down twice in a short span of time. Power out, power up, phones try to upgrade, power down, these phones pooched. Other 40-50 phones ok. It's possible the phones do get an IP address but then go no further. Consider if they lost the ability to identify themselves as phones that need to use the phone aux vlan. They would then have a regular data subnet address and be on the data vlan. So another thing to try under that hypothesis would be to configure a port that is on just the voice vlan. hmm.
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 1

Author Comment

by:amigan_99
ID: 40626336
Well I was excited to try out the theory - but alas no-go. I put the phone onto a PoE port configured as access port for only the phone vlan and no aux vlan. But the behavior was the same: The screen and all five lights come on for a second and then only the speaker light in the lower right stays lit constantly green. There is no activity at the Ethernet level. I cleared the counters for the port before plugging in the phone and there are 0 bytes in or out and the port shows DOWN despite having that green light lit on the phone. So not even a DHCP request message is making it out of the phone if there's 0 traffic and the phone goes dead before there's an opportunity to slap a static address on it. To rule out that the power negotiation was pooching things I patched in a phone PS 48v .38amp. This adds nothing. I again tried holding down the # key while booting but the phone is not recognizing that. Looking like three bricks at this point. ??

c3560-1#sho int gi 0/13
GigabitEthernet0/13 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 5475.d041.b98d (bia 5475.d041.b98d)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:02:48, output hang never
  Last clearing of "show interface" counters 00:02:17
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
0
 
LVL 20

Accepted Solution

by:
José Méndez earned 500 total points
ID: 40627157
Yes, pretty much =(
0
 
LVL 1

Author Closing Comment

by:amigan_99
ID: 40627269
Thanks again for the help Mr. Wonka!
0
 
LVL 1

Author Comment

by:amigan_99
ID: 40627277
For the sake of others who cross this path in the future - I found one more knob to turn. A Cisco page suggested booting the phone without the handset in the cradle. For a few seconds I thought I'd struck pay dirt. Everything stayed lit for a few more seconds than if you booted with the handset in the cradle. Interesting that it makes a difference but the net effect was the same in the end.
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 40627340
Very interesting, I didn't know that one, thanks for sharing.
0
 
LVL 1

Author Comment

by:amigan_99
ID: 40628727
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
facetime for windows7 6 59
VOIP client on iOS/Android 6 58
Callkit and Android comparison 4 41
Copy of a Manual for a Cisco Systems IP Phone Model 3844-13-1086 2 448
Although VoiceOver IP has been around for a while, internet connections have only recently become fast enough to provide good call quality. Now, VoIP has become a real option for businesses looking at ways to improve their business model. In this ar…
I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now