Solved

dynamics crm 2013 email body field locked

Posted on 2015-02-22
18
1,005 Views
Last Modified: 2015-03-03
I have recently installed Dynamics CRM 2013 onto Windows Server 2012 R2. I also have Exchange 2013 running on another Server 2012 R2 system. Successfully linked my CRM account and a test User account to Exchange; incoming and outgoing tested successfuly. All seems to be working fine, with the exception of creating email content. No customization has been done to the email form in CRM 2013, it is standard OOTB . When myself (system administrator) or the test user creates an email all the fields are accessible, such as From, To, Subject, Attachments (after saving), etc. but once I try to click within the email body area to type in the email contents, nothing. The field is locked, test user, nor myself can add anything into the body field to create an email. I've Googled this for the last two days to no avail, desperate need of some guidance.

I've looked at the Form customization form to see if there are any locking selections. Locked selection "Lock the field on the form" is NOT checked. Field behavior "File is read-only" is NOT checked either.
0
Comment
Question by:Louie Alvarez
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 7
18 Comments
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40624538
Does this apply only to emails for the administrator or also to other activities such as tasks?
0
 

Author Comment

by:Louie Alvarez
ID: 40624716
This applies to my administrator account as well as users.

The difficulty in locating a solution is it is only the email body field that is locked. I can create tasks, appointments, phone calls without issue all those fields are open and editable, without issue.

I even gave my admin account every single role on the CRM 2013 choices to see if I could at least my admin account could get an accessible/editable email body field. To no avail, even with ALL security in my favor the field is still locked.
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40624767
This is very strange and something that I've not come across before.  In the header area of the email form, what do you see for Status Reason?  For a new e-mail, I'd expect to see, Draft.

Also, can you post a screenshot that shows the body area?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Louie Alvarez
ID: 40624778
Yes the header status reason does state Draft. Snapshots here:
 
 Top portion of email screenBottom portion/ email body screen shot
0
 

Author Comment

by:Louie Alvarez
ID: 40624785
As you can see I can set To, Subject, Attachment, Priority, Due, Regarding (just did not choose anything). Within the E-mail body I cannot insert a template (although I can click on the button and the template subject will insert as it should) or article. This field is imply locked from access even from myself the administrator :(

---

BTW, this is an upgrade within the last week from CRM 4 -> CRM 2011 -> CRM 2013 (if this helps at all).
0
 

Author Comment

by:Louie Alvarez
ID: 40624954
I've now tried to access the email body in IE, Chrome, Firefox, Safari to no avail. I did check "developer tools" within IE and this is the info I believe is the problem area:

div class="ms-crm-Inline-Edit ms-crm-Inline-Edit-email-body">

    <table id="description_i" class="ms-crm-Email-Body" cellspacing="0" cellpadding="0" width="100%" height="100%" mainelement="true" attrformat="emailbody" aria-labelledby="description_c description_w" controlmode="alwaysedit">
        <tbody>
            <tr id="descriptionHtmlBar" height="26"></tr>
            <tr id="trBlockMsg"></tr>
            <tr>
                <td class="ms-crm-Email-Body" {0}="" style="height:100%">
                    <div style="-webkit-overflow-scrolling:touch; overflow:auto; height:100%">
                        <iframe id="descriptionIFrame" class="ms-crm-Email-Body" frameborder="0" title="Email body" tabindex="1070" src="/_static/blank.htm" url="/ORG/_controls/emailbody/msgBody.aspx?id={197B4894-F9BA-E411-80D5-00262D1F0DAC}&entityType=email" name="descriptionIFrame" sandbox="" security="restricted">

The last setting security="restricted" looks to be the problem. I guess my question is does anyone know where this code is located to make a global change for ALL users? I am guessing that would correct this issue.
0
 

Author Comment

by:Louie Alvarez
ID: 40626285
I managed to locate a similar known issue via Microsoft KB Article ID: 2916958: http://support.microsoft.com/kb/2916958

Symptoms
If you create a new email message in the Microsoft Dynamics CRM 2013 web application, you discover that you cannot modify the Description field (email body). This problem occurs if you're using the latest version of Google Chrome.

That is indeed my symptom, but resolution does not apply, nor work

Resolution
This issue is resolved by Update Rollup 1 for Microsoft Dynamics CRM 2013.

I am in the latest update (SP1 v6.1.2.112) so this resolution did not work for me and I am using IE anyway for CRM access. I did try with IE, Chrome, Firefox and Safari yet none allow me to modify the email body description field. Anyone out there with any suggestions?
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40626359
Interesting that you found that article.

That makes me wonder whether it is a security setting in IE, have you tried adding the URL you use for CRM either to the Local Intranet zone in security settings in IE?
0
 

Author Comment

by:Louie Alvarez
ID: 40626451
I'll try it right now.

Figured I would reinstall the SP1 w/ UR2 again and see if that after the reboot makes any difference. Nope, installing the SP1 w/ Update Rollup 2 didn't change anything

Also turning off "Enable Protected Mode" on trusted, local, internet didn't change anything either.

I'm going to experiment with the security settings for .NET Framework in the internet zone and local intranet to see if that makes any difference.
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40626478
Ah, but did you add the URL for your CRM to Local Intranet?
Local-Intranet.JPG
0
 

Author Comment

by:Louie Alvarez
ID: 40626564
Just tried the local intranet suggestion, as well as enabled all .NET framework selections to no avail. Been trying to figure this out for over a week now and I am still at a complete loss. I really appreciate your suggestions feridun but still can't access the email body (description) field.

If you know where the security"restricted" setting is as noted below (found this when I right mouse click and click on "inspect element" maybe that will unlock this field.

                       <iframe id="descriptionIFrame" class="ms-crm-Email-Body" frameborder="0" title="Email body" tabindex="1070" src="/_static/blank.htm" url="/ORG/_controls/emailbody/msgBody.aspx?id={197B4894-F9BA-E411-80D5-00262D1F0DAC}&entityType=email" name="descriptionIFrame" sandbox="" security="restricted">


The last setting security="restricted" looks to be the problem. I guess my question is does anyone know where this code is located to make a global change for ALL users? I am guessing that would correct this issue.
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40626631
Hmm, I've run out of ideas. Sorry.

I agree with you that the security="restricted" does seem to be the culprit but I can't suggest a way to fix that.

You might have to log a call with Microsoft Support.

BTW, have you tried another browser such as Mozilla?
0
 

Author Comment

by:Louie Alvarez
ID: 40626638
Here is a pick of the email form configuration tab. Notice the lock next to the Decription title? This is what I am trying to unlock.
Email Form Description (body) Field Locked
Here shows that the form should not be locked, according to the field properties
Email Form Field Properties
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40626930
That lock symbol does not make the field read-only. It means that you can't remove it from the form.
0
 

Author Comment

by:Louie Alvarez
ID: 40627209
Yes I tried to remove it from the form to rebuild the email form and it is locked from removal. So the lock symbol now is clear. Nothing I've tried has made a difference so hopefully someone has suggestions or a call to MS for guidance. I still believe it is the security="restricted" in the code that is the culprit but can't find where to remove it. I have tried all the major browsers; IE, Chrome, Firefox & Safari, tried on 4 different computers even directly on the server, to no avail :(
0
 

Accepted Solution

by:
Louie Alvarez earned 0 total points
ID: 40627241
Finally found the source of my problem online after hours, days of searching...

The setting is found in Settings->Administration->System Settings [Email Tab], section 'Set E-mail form options'.

The setting is labeled 'Use secure frames to restrict e-mail message content'. You need this set to 'No' for IE 10+ and/or Chrome (current) to properly function when creating EMAIL activities.

I can now use the email body/description field!
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 40628075
Doh!  I should have thought to mention trying that setting - although I have to say I have never encountered your issue probably because I have that setting set to No.

Glad you got there in the end and definitely one to remember.
0
 

Author Closing Comment

by:Louie Alvarez
ID: 40641422
After days, hours of searching online and trying numerous suggested solutions, this turned out to be a simple selection within the Administration | Settings | Email area. Problem resolved!
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you irritated by repeating emails issue in Microsoft Outlook 2016 after recent update ?  Lets’ see how to resolve and prevent duplicate emails in the Outlook 2016 using some simple techniques.
Desired Skill Set for Microsoft Dynamics CRM Technical Resources – Part II
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question