Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Exchange 2010 cluster issue

Posted on 2015-02-22
4
Medium Priority
?
226 Views
Last Modified: 2015-02-24
Hi Experts,

I have recently started to receive issue with our exchange 2010 DAG, one of the primary site DAG member server which is holding the active DB copy move the DB to another member server in the primary site.

DAG Member : Primary Site: Server01(DB01,DB02), Server02(DB03,DB04)
Secondary site: Server04 (DB01,DB02,DB03,DB04) passive copy

As part of the investigation, notice that Windows service 'ClusSvc' is stopped and the server which is moving the active DB copy is doing the v-motion during that time and causing the cluster service to fails and move the DB.

I have found that Vmware has article addressing the Microsoft Failover Cluster for Exchange best practices by adjusting Samesubnetdelay to two seconds and keeping the SameSubnetThreshold to 5, which gives a 10 seconds threshold heartbeat.

http://www.vmware.com/files/pdf/using-vmware-HA-DRS-and-vmotion-with-exchange-2010-dags.pdf


Could you please advise how can I  investigate how many seconds the Exchange box lost the network connectivity during the Vmotion, does the Cluster log  helps to identify? and adjusting Samesubnetdelay to two seconds and keeping the SameSubnetThreshold to 5, which gives a 10 seconds threshold heartbeat, will that help. Please advise.
0
Comment
Question by:ipsec600
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 44

Assisted Solution

by:Amit
Amit earned 300 total points
ID: 40625728
I saw the pdf document and VMware is recommending to use 2 second and MS recommend max 10 second, so I don't see any issue in changing it to 2 sec as VMware recommending. I suggest implement and see if that resolve the issue or not.
0
 
LVL 9

Accepted Solution

by:
Veerappan Sundaram earned 600 total points
ID: 40625810
This is know issue with VMware and Exchange 2010 cluster service. First, check the underlying hardware platform bottlenecks - instead of adjusting the threshold. If you do not have any option to fix the hardware layer performance bottleneck, then you have to think about modifying the thresholds.
VMware logs should give you a clear indication for the V-motion.
If the problem is at hardware platform level, then cluster logs will have the information about disk/network response latency.

Thanks,
Veera.
0
 
LVL 19

Assisted Solution

by:Adam Farage
Adam Farage earned 600 total points
ID: 40626156
Could you please advise how can I  investigate how many seconds the Exchange box lost the network connectivity during the Vmotion

You are doing a cold boot when the vmotion is done? Doing a live vmotion is not supported by Microsoft and can cause some issues.
0
 

Author Comment

by:ipsec600
ID: 40628233
Thanks Guys for the clarification.
0

Featured Post

2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
how to add IIS SMTP to handle application/Scanner relays into office 365.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question