[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 63
  • Last Modified:

How do i get outlook to stop changing the proxy server for exchange URL

I'm trying to get Outlook anywhere working for remote users both with domain joined machines and without.  For testing purposes i'm doing this from a non-domain joined pc outside of the network. Server is SBS2011. The problem i'm currently experiencing is that i manually put in my settings, please see attached,with the correct proxy settings.  The server and name check fine.  

Once outlook restarts and opens, prompts for password, after i put in password outlook tries to connect and eventually disconnects.  When i check the proxy server setting has changed from webmail.company.com to company-server (The internal name of the exchange server).  I then have to change it back where it prompts that outlook will need to be restarted.  I don't restart outlook and shortly after i see outlook has connected to exchange.  How do i stop this from changing?
Proxy.pdf
0
Botsasc
Asked:
Botsasc
  • 4
1 Solution
 
Will SzymkowskiSenior Solution ArchitectCommented:
Do you have autodiscover configured properly for external users? Also do you have your external/internal URL's configured properly on your Exchange server?

I think you might have a DNS issues based on the settings changing. Your autodiscover is picking up the internal name of your server which is not accessible on the internet. You need to configure your virtual directories properly, along with the external autodiscover settings as well.

Will.
0
 
BotsascAuthor Commented:
When i run the get-outlookprovider command i get the following:

[PS] C:\Users\Admin\Desktop>get-outlookprovider

Name                          Server                                          CertPrincipalName                                   TTL
----                          ------                                                                -----------------             ---
EXCH                                                                                                                                                       1
EXPR                          company-server                   msstd:webmail.company.info                         1
WEB                                                                                                                                                         1

Should the company-server be changed to webmail.company.info?

ExternalHostname : webmail.company.info is correct.

webmail.company.info resolves internally to the exchange server.
0
 
BotsascAuthor Commented:
[PS] C:\Users\COMPANYAdmin\Desktop>Get-ClientAccessServer | FL

RunspaceId                           : 1ca03375-0edb-4e9b-bbc6-4318b894fba3
Name                                 : COMPANY-SERVER
Fqdn                                 : COMPANY-SERVER.COMPANY.local
OutlookAnywhereEnabled               : True
AutoDiscoverServiceCN                : COMPANY-SERVER
AutoDiscoverServiceClassName         : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri       : https://webmail.COMPANY.info/autodiscover/autodiscover.xml
AutoDiscoverServiceGuid              : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
AutoDiscoverSiteScope                : {Default-First-Site-Name}
AlternateServiceAccountConfiguration :
IrmLogEnabled                        : True
IrmLogMaxAge                         : 30.00:00:00
IrmLogMaxDirectorySize               : 250 MB (262,144,000 bytes)
IrmLogMaxFileSize                    : 10 MB (10,485,760 bytes)
IrmLogPath                           : C:\Program Files\Microsoft\Exchange Server\V14\Logging\IRMLogs
MigrationLogLoggingLevel             : Information
MigrationLogFilePath                 :
MigrationLogMaxAge                   : 180.00:00:00
MigrationLogMaxDirectorySize         : 10 GB (10,737,418,240 bytes)
MigrationLogMaxFileSize              : 100 MB (104,857,600 bytes)
IsValid                              : True
ExchangeVersion                      : 0.1 (8.0.535.0)
DistinguishedName                    : CN=COMPANY-SERVER,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=
                                       Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN
                                       =Configuration,DC=COMPANY,DC=local
Identity                             : COMPANY-SERVER
Guid                                 : 983e4d9c-b004-4ef7-9e7a-e9cabafa9e9d
ObjectCategory                       : COMPANY.local/Configuration/Schema/ms-Exch-Exchange-Server
ObjectClass                          : {top, server, msExchExchangeServer}
WhenChanged                          : 1/28/2015 10:41:45 AM
WhenCreated                          : 2/12/2013 12:48:20 AM
WhenChangedUTC                       : 1/28/2015 8:41:45 AM
WhenCreatedUTC                       : 2/11/2013 10:48:20 PM
OrganizationId                       :
OriginatingServer                    : COMPANY-SERVER.COMPANY.local
0
 
BotsascAuthor Commented:
managed to resolve this issue by following the following URL. http://sanjaysingh11.blogspot.com/2014/03/there-is-problem-with-proxy-servers.html
0
 
BotsascAuthor Commented:
The recommended solutions didn't help.  Found the following link on the web, which resolved the issue.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now