Exchange Bounce Back Message Not Being Sent

In our organization, people mistakenly send email to the entire IT Department for situations that are more appropriate to email the IT Help Desk. Our IT Director made the decision to block everyone from emailing the IT Department distribution group, but we want to keep the group for intradepartmental communication. So simply deleting the group is not an option.

I've hidden the distribution group from the Global Address list to discourage new offenders. For the people who already have the address in their auto-complete, I've created a Transport Rule to accomplish the goal. This is how it reads:
Apply rule to message
when any of the recipients in the To or Cc fields are IT Department
send Delivery not authorized, message refused to sender with 5.7.1
except when the message is from member of IT Department

Open in new window

I should mention that I am an Exchange novice. The bounce back portion of the rule is the default one that appeared when I took a guess and checked the box for "send bounce message to sender with enhanced status code" assuming that's what I wanted to be done. The rule functions except for the bounce-back. The entire IT Department is not being disrupted for every little issue, and we are able to email each other from within the department, but people from outside the department didn't know that their messages were being dropped silently.

Temporary Work-Around:
For the time-being, I added the following portion to the rule so the emails don't just disappear.
    and redirect the message to IT Help Desk

Open in new window

So for now people will continue to get serviced by the IT Help Desk, but they will never know that they're actually emailing the wrong address.

I double checked the settings under Organization Configuration -> Hub Transport -> Remote Domains to verify that "Allow Delivery reports" and "Allow non-delivery reports" are both enabled. That's about the extent of my research thus far.
Who is Participating?
Will SzymkowskiConnect With a Mentor Senior Solution ArchitectCommented:
The above would not be the correct method, to accomplish this. I would not be hiding the Distribution Group from the GAL. Mail can still flow to a hidden mailbox if they know the address. What you need to enable is Message Delivery Restrictions.

- open EMC
- find the mailbox,
- properties, mail flow settings tab
- Message Delivery Restrictions
See below screenshot.
Also when you enable Message Restrictions if users email this DL and do not have permission they will get an auto bounce back stating that they cannot send to the DL because of security restrictions.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.