Hosted Website Taking 30 Seconds To Load

We recently setup a website for company projects, using a domain that we've owned for years but never used. The webpage at JohnDoe.net/projects takes upwards of 30 seconds to load. Twice I had thought I'd solved the problems: Once when we first set it up we realized we had added the new host to our registrars' domain servers but had forgotten to remove the old host; Second when I noticed that clearing each user's browser cache seemed to solve their problem. But the problem keeps rearing its head, then resolving itself. I'm hesitant to publish the domain, for security reasons, since life on the Internet is a virtual cesspool of criminals. :) The host server is running Apache.  Let me know how much more info might be needed.
slamondAsked:
Who is Participating?
 
Benjamin MOREAUConnect With a Mentor Project ManagerCommented:
For you perf problem, I think you can first try to test your website with this online tool : http://www.webpagetest.org/

It will say to you why your website is slow, and what elements is responsible of that.
0
 
slamondAuthor Commented:
Thanks I'll give that a try anyway, but I just got this message from one of our employees:
"It should be fixed now. Apparently there was an incorrect A Record within the web host. The tech support team removed it. I think everything should be working correctly now. I’ll keep you updated. "
I will keep this question open until I confirm that all is well.
0
 
slamondAuthor Commented:
The solution was fixing the A record entry.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.