Solved

Exchange 2003 not sending to 2010

Posted on 2015-02-23
20
9 Views
Last Modified: 2016-06-24
Hello I am in the process of migrating from exchange 2003 to 2010. Everything is working ok except I am unable to send email from 2003 mail accounts to 2010. I get the following error

test2010 on 2/23/2015 3:44 PM
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <agcex2.ECC.COM #5.7.1 smtp;550 5.7.1 Unable to relay for test@ECCtest.org>
I have tried setting the smtp relay settings to allow all as a test with no luck. I am also able to telnet between the two servers on port 25. Any ideas on what might be causing this?
0
Comment
Question by:ksaveit
  • 10
  • 9
20 Comments
 
LVL 4

Expert Comment

by:szichen
ID: 40626723
Do you have relaying disabled in Exchange 2003?
0
 

Author Comment

by:ksaveit
ID: 40626751
No as of right now for my default smtp virtual server properties, I have under the relay restriction tab my 2003 and 2010 servers ip addresses and the only allow the list below ticked. I also have the allow all computers who successfully authenticate to relay box checked.
0
 
LVL 4

Expert Comment

by:szichen
ID: 40626783
Have you created the connector between exc2003 and exc 2010 and allowed exc2003 to send mail over the connector?
0
 

Author Comment

by:ksaveit
ID: 40626867
I created two connectors from 2010 exchange powers hell one for each way. I have also tried removing the and re adding them again. Does the connector between exchange  2003 and 2010 use the smtp virtual server to send?
0
 
LVL 4

Expert Comment

by:szichen
ID: 40626893
Only one connector needs to be created.
0
 

Author Comment

by:ksaveit
ID: 40627051
This is how my setup looks as of now.Screen-Shot-02-20-15-at-09.39-AM.PNG
0
 
LVL 4

Expert Comment

by:szichen
ID: 40627164
Do you have a receive connector in  Exchange 2010?
0
 
LVL 4

Expert Comment

by:szichen
ID: 40627199
Do you have a smart host on the SMTP virtual server of the Exchange 2003 server? If you do then that might be your issue.
0
 

Author Comment

by:ksaveit
ID: 40627275
I have the default  receive connector on my exchange 2010 and have placed my 2003 exchange  ip in the accepted servers. I don't have a smart host configured on my smtp server. Should my default smtp server be set for all unassigned traffic on port 25 or should it be set to my ex2003 ip address?
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 4

Expert Comment

by:szichen
ID: 40627286
In exchange 2010, you can leave it as all unassigned traffic.
In exchange 2003, it can point to its own IP address.
0
 

Author Comment

by:ksaveit
ID: 40627312
Ok I wanted to make sure that is how I have it set up now.
0
 

Author Comment

by:ksaveit
ID: 40628022
Any other ideas or test I can try?
0
 

Author Comment

by:ksaveit
ID: 40628848
Anything?
0
 
LVL 4

Expert Comment

by:szichen
ID: 40629785
OK so you said that everything else works...
* so you can send to 2003 from 2010
*you can send from 2003 to external
*you can send from 2010 to external
* you can receive from external to 2003

Is this correct?
0
 

Author Comment

by:ksaveit
ID: 40630442
I went through and tested all mail again today. I had to disable my internet send connector on the 2010 exchange because if I leave it on I start to get the unable to relay error when I try to send from my 2003 server to outside. I also am not able to receive from outside to my 2010 exchange at this time. Otherwise all other mail traffic is fine 2003 can send external and internal and 2010 can send to 2003. Could this be my ISP blocking my 2010 server from sending or receiving?
0
 
LVL 4

Expert Comment

by:szichen
ID: 40631800
Ahhhh... so everything else does not work as it should.

OK...

Are you able to send me screenshots of the setup in Exch 2010 from the exchange management console? You can hide the details
In particular;
* Organization Configuration>>hub transport >>Accepted Domains
* Organization Configuration>>hub transport >>Send connector>>Connector "Properties>>Network tab

In exchange 2003, is there anything in the system logs for the relaying issue?
0
 

Author Comment

by:ksaveit
ID: 40632973
Thanks for the reply it is appreciated. Here is the screen shot of the accepted domains. I removed the outgoing send connector as of now because I with it set up I was not able to send out through the 2003 server without getting the unable to relay error. Is it possible for me to email the log file to you? I have also noticed that my mail.domain.org is tied to my exchange 2003 external IP address and that my external IP for my 2010 exchange does not have a dns name referenced to it. Could this be my issue?Screen-Shot-02-26-15-at-08.06-AM.PNG
0
 

Accepted Solution

by:
ksaveit earned 0 total points
ID: 40641953
This ended up being a issue with my ex2010 mx record. After I made a change to that everything started flowing.
0
 
LVL 4

Expert Comment

by:szichen
ID: 40645913
Sorry been away for a while.
Great!! good to know its all working. Looking back now, I think there was some confusion in the start and the problem should have been broken down further. Anyway, all the best with the rest of the configuration.
0

Featured Post

Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now