Why are my VBA macros being listed by file name in Excel?

After clicking the Run Macros button, I have selected the drop down "This Workbook", and some of the macros are being shown by their name only, and some are being shown with the workbook name appended to the front. Can I get rid of those appendages somehow?
shampouyaAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
gowflowConnect With a Mentor Commented:
Usually when you see a macro prefixed with the File name this means that your macros settings are not activating macros. or you have more than 1 workbook opened and you can see the name of the macro affected to the workbook. But as you already mentioned that you first select this workbook from the dropdown then my guess is that your macros settings are not enabled.

When you open the your workbook do you see a button OPTIONS with a security warning that macros are disabled ? if yes then simply press on Options first and enable macros then go to Run Macroes and see if the name of the workbook is still there. It should have disappeared.

gowflow
0
 
ProfessorJimJamCommented:
they must have been stored in your personal.xlsx  which is in the XL start up folder.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.