Impossible to send email with attachments with a mobile device

Hi,
I need some help because I'm not able to resolve this case.
I got a MS Exchange 2010 and some mobile device (about 15-20 iOS/Android/WPhone).
It's impossible to send an email with those device with more than about 600-700kB of attachments.
I got a message on the device "failed to send" or something like this.
I've activate the activesync logs in ECP but nothing relevant. Nothing MS logs.
No problem with outlook client.
thank you.
P6FERAsked:
Who is Participating?
 
P6FERAuthor Commented:
Hi after some googling I've found the answer, it was on the NGINX conf file, need to add a line in the http bloc :

client_max_body_size 20m;

Open in new window


then reload NGINX and it's ok.

Thanks for trying to help me, I didnt talk about my NGINX reverse.proxy
0
 
HariomExchange ExpertsCommented:
Have a look in Exchange Manager > Organization Config > Hub Transport > Accepted Domains

Make sure the <domain>.local is set as the default. For some reason on ours the default domain got changed to our external mail domain.

Just right click on the .local domain and choose "Set as Default". Once we changed that we were able to send from the mobile devices.

Ref :https://social.technet.microsoft.com/Forums/exchange/en-US/955dd9f6-597a-4100-bb72-48fba4fe1e51/unable-to-send-mail-using-activesync-in-exchange-2010-server-on-iphone-or-windows-mobile-61?forum=exchange2010
0
 
P6FERAuthor Commented:
Hi viralr,
I don't think this my situation, we can send email through mobile device but there's a problem sending email WITH attachments over 600kB. Anyway this setting was ok.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Xi MingCommented:
Hi,

The alternative way is to upload the file to cloud, eg dropbox or google drive, and send the link through the email, as most mobile devices have a limit to email attachment sizes.
0
 
P6FERAuthor Commented:
Thanks for your comment, it could be a solution but it's too complicated for users. Even more in a pro environnement.
0
 
Xi MingCommented:
Hi P6FER,

Go to Mobile device mailbox policy settings > Max attachment size.
Set value as "Unlimited".
0
 
P6FERAuthor Commented:
You mean in the EAC ?
The max attachment size option refers to the attachments that are downloaded to the mobile when consulting an email with attachments I think.
0
 
Xi MingCommented:
I see, tell us if you have any updates on this issue so that we can learn too. Thanks
0
 
P6FERAuthor Commented:
Found the answer by myself
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.