Slow Incoming Mail with Attachments - Exchange 2013

Hi All,

Hope somebody could help me on this!

We have a strange problem with our Exchange server. Currently running Eachange 2013 with all roles enabled on single server.

Port Re-Direct and Reflector Service is been used from www.noip.com.

Mail Flow incoming is:-

Sender -->> No IP -->> Our Exchange Server

NO IP are saying everything is OK there side.

When a user sends an e-mail with no attachment delivery time is approx 30 seconds. When the same user sens with an attachement (even 500kb) delivery time is sometime 2+ hours.

Im no Exchange GURU so dont even know where to start looking.

As part of fault finding so far:

Server is Windows 2008 R2 (64 Bit), Fully Patch
Exchange Fully Patched
Mail Filter Disabled on Exchange

Server Specs are:- , 8 Gig RAM, only 5 Gig Used. Running on ESXi. 12 Mailbox's currently on there.

Cheers
TME
LVL 1
TrustGroup-UAEAsked:
Who is Participating?
 
TrustGroup-UAEAuthor Commented:
I am going to close this issue as it seems to have resolved itself. Dont know how but will keep an eye and update if the problems returns.

Cheers
TME
0
 
SreRajCommented:
Hi,

This could happen if there is a antivirus/malware scan being done on the mail and it is taking more time than normal. If there is a mail tracking option available with NOIP, please try tracking a delayed mail and see the timestamps and try to find out where the delay has happened. Also you could go thru the header of the delayed mail and see which device has created delay in processing the mail.

You could use the following link to analyze header.

http://mxtoolbox.com/EmailHeaders.aspx

Following link has information on how to collect header from a mail.

http://mxtoolbox.com/Public/Content/EmailHeaders/#Outlook_2010
0
 
HariomExchange ExpertsCommented:
1) Do you have any AV on any of the servers? If so, do you have it configured to scan attachment?

May be antivirus software is scanning attachment e-mail which causes delay try to disable antivirus .

2) Check Exchange Manager > Organization Config > Hub Transport > Accepted Domains

Make sure the <domain>.local is set as the default. ,Just right click on the .local domain and choose "Set as Default".
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
TrustGroup-UAEAuthor Commented:
Hi Guys,

Many thanks for you response.

AV is disbaled on the Server. This was done as part of Diagnostics. Also I cant find Hub Transport in the Organzation Config Page?

Cheers
TME
0
 
SreRajCommented:
Are you looking at the Exchange Management Console in an Exchange 2010 Server.

Also, did you check header of the delayed mail and find out any host which is taking time in relaying mails.
0
 
TrustGroup-UAEAuthor Commented:
Issue went away on its own.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.