VB/HTML button - i cant get it to work

Hi guys,

i'm trying to add a button in my request/response, but for some reasone it not working and i cant figure out why :S
If i do it with a simple text it works

kindly help:

this is what i have:

else
		Response.Write L_PasswordChanged_Text & " " & L_System_Login &".<p>"
		Response.write ("<a href='https://www.google.dk/'>test</a>") '<--this works but no button
		Response.Write ("<input type='button' id='butTest' value='Knap' onclick='window.location=https://www.google.dk/'>") '<---- doesn't work
		Response.Write "<br><H3><a href=" & Server.HTMLEncode(Request.ServerVariables("HTTP_REFERER")) & ">" & L_Back_Text & " </a></H3>"
		Response.End

Open in new window

LVL 1
HakumAsked:
Who is Participating?
 
HakumAuthor Commented:
I think i figured it out. since this works:

Response.Write ("<input type='button' id='butTest' value='Knap' onclick=window.location.href=https://www.google.dk/'>")

Open in new window

0
 
FarWestCommented:
could you post the source text "from view source" of the generated html
0
 
HakumAuthor Commented:
Here it is:

<HTML style="font-family: arial;">
<p><img src="/iisverpwd/shb-logo166x18-hex005fa4.png" style="float:right;"></p>  
<h2 style="font-family: arial;">HITS/Espresso Password
</h2>

<head>
	<META HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">
</head>
<title>HITS Autenticering</title>
<STYLE>
</STYLE>

	
<BODY BGCOLOR=#FFFFFF LINK=000000 VLINK=000000>





<!-- Windows NT Server with IIS  -->

	<TABLE BORDER=0 CELLPADDING=0 CELLSPACING=0>
	<TR VALIGN=CENTER>
		<TD></TD>
		<TD WIDTH=20> </TD>
		<TD><FONT SIZE=+3 COLOR=#000000><B><BR> <FONT SIZE=-1><FONT></B></FONT></TD>
	</TR>
	</Table>
   

<!-- Windows NT Workstation with PWS  -->

<p style="font-family: arial;">

Dit password er hermed ændret.  Du kan få adgang til xxxxxxx Applikationer ved at klikke på et af de nedenstående links.<p>
<a href='https://www.google.dk'>Espresso</a>

Open in new window

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
KimputerCommented:
Are you sure it's correct ? Source says "test", while your page says "Espresso" (and misses two lines)?
0
 
FarWestCommented:
I mean after executing the code, and the control is shown in the form,
or this is not happening?
0
 
HakumAuthor Commented:
Sorry sent you the wrong source :S

this the correct one

<HTML style="font-family: arial;">
<p><img src="/iisverpwd/shb-logo166x18-hex005fa4.png" style="float:right;"></p>  
<h2 style="font-family: arial;">HITS/Espresso Password
</h2>

<head>
	<META HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">
</head>
<title> HITS Autenticering</title>
<STYLE>
</STYLE>

	
<BODY BGCOLOR=#FFFFFF LINK=000000 VLINK=000000>




<p style="font-family: arial;">
<br>
Dit password er hermed ændret.  Du kan få adgang til xxxxxx Applikationer ved at klikke på et af de nedenstående links.<p><br><br><a href='https://incident.shbmain.shb.biz'>Incidentrapportering</a><input type='button' id='butTest' value='Knap' onclick='window.location=https://www.google.dk/'>

Open in new window

0
 
HakumAuthor Commented:
Thanks alot tho!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.