Issues with Outlook in Citrix - hyperlinks not opening

I have an issue with Citrix XenApp 6.0.0 with an installation of Outlook 2010. As suggested, hyperlinks in Outlook aren't working. I don't get any error messages, the links simply to not open. This is when using Citrix via the Receiver client, or via the web portal. When you log into the server directly and try Outlook, links in emails work fine.

The server runs fully-patched Outlook 2010 and IE11 version 11.0.9600.17633

I have tried the following:

Chrome used to be on the server, and this has been resolved by a colleague once. The standard resolves for Chromr were run through; the product was uninstalled, the registry cleared, IE made the default again - this *worked* for months
Behaviour is not dependent on permissions - issue occurs if the user is a local admin
Server has been rebooted
Windows is fully patched
A new user with a fresh profile has the same issue
Firefox is on the server; I have switched to this, then back to IE as default

I have also tried applying the following reg keys (via batch file, which runs successfully)

REG ADD HKEY_CURRENT_USER\Software\Classes\.htm /ve /d htmlfile /f
REG ADD HKEY_CURRENT_USER\Software\Classes\.html /ve /d htmlfile /f
REG ADD HKEY_CURRENT_USER\Software\Classes\.shtml /ve /d htmlfile /f
REG ADD HKEY_CURRENT_USER\Software\Classes\.xht /ve /d htmlfile /f
REG ADD HKEY_CURRENT_USER\Software\Classes\.xhtml /ve /d htmlfile /f

Open in new window


I have been advised to try adding these keys, but I get an error that the keys are locked. If I have to take ownership of those keys per user to fix this, then that *isn't* a practical fix for this situation.

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\htmlfile\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" %1"
[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\https\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\IE.HTTP\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\IE.HTTPS\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\mms\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
"MPlayer2.BAK"="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\pnm\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\rtsp\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\rtspu\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"

Open in new window

LVL 6
arrorynAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CoralonCommented:
Is your Citrix fully patched?   It's obviously not a problem with Outlook itself, since it works properly on the server.  

Do you have the option to just rebuild the server?  If it's only IE & Outlook, then that could be done in a few hours.

Coralon
Sekar ChinnakannuStaff EngineerCommented:
did you enabled server to client content redirection , if not enable the same and check
Dirk KotteSECommented:
follow up to the answer from Sekar ...
try to explicit disable server to client content redirection also
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

arrorynAuthor Commented:
Thanks for the responses so far. A rebuild isn't an option, so I will check the content redirection settings, thanks.
arrorynAuthor Commented:
did you enabled server to client content redirection , if not enable the same and check

I have enabled this, but this utilises the local browser; I want the user to use the server's browser instance.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CoralonCommented:
That proves that Citrix' mechanics are working properly.  
So, you can turn that off.. In fact, I would specifically disable it in your Citrix policies.

Next step is to verify your protocol handler registry entries (HKEY_CLASSES_ROOT\http\shell\open\command) and check the default command.  It should point to c:\program files (x86)\internet explorer\iexplore.exe %1 (or something similar).  Also check your https setting, etc.

Coralon
arrorynAuthor Commented:
Reinstalling and then removing Chrome, removing all registry keys, appears to have resolved this issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.