We help IT Professionals succeed at work.

csv default column formatting is all wacky

finnstone
finnstone asked
on
whenever i save csv files, the attached happens

even if i save it in columns before saving!

you can see all the values are crammed in one column
special-1.5-cdone.csv
Comment
Watch Question

Phillip BurtonDirector, Practice Manager and Computing Consultant
Awarded 2014
Top Expert 2014

Commented:
No, I can't see that. When I open it in Excel, it opens fine.

How are you opening it into Excel?
Muhammad MullaSystems Administrator

Commented:
Can you post a screenshot, please

Author

Commented:
yes i open in excel 2013
Phillip BurtonDirector, Practice Manager and Computing Consultant
Awarded 2014
Top Expert 2014

Commented:
How? File - Open or a different way?

Author

Commented:
double click the file from windows explorer.
Director, Practice Manager and Computing Consultant
Awarded 2014
Top Expert 2014
Commented:
That's why. Try opening Excel first, and then go to File - Open, change the file type to "*.csv", and open it there.

Author

Commented:
awesome!

Author

Commented:
very helpful
Rob HensonFinance Analyst

Commented:
Saving file to Downloads folder and then double clicking in Windows explorer opens file correctly for me in Excel 2010.

When looking at the CSV file in Explorer, what icon does it have against it? Maybe default application for CSV files isn't set correctly or its an issue with Excel 2013 default settings.

Thanks
Rob H

Author

Commented:
it has an a icon ...different than the excel files

yes i got to think its excel 2013 default settings are messed up
Rob HensonFinance Analyst

Commented:
Also, I notice that the filename has two fullstops in it:

special-1.5-cdone.csv

Some applications see this as multiple extensions which could suggest a virus.

The standard csv/excel icon is similar to the Excel file icon but with a letter a on the spreadsheet beneath the excel logo part of the icon.

Thanks
Rob H