Video System

Does anyone work with IP video camera systems?  Specifically Video Insight.  

I am trying to integrate Active Directory with it instead of making individual users on the camera system itself.  

I have a service account for it setup.  I point it at the domain controller.  If successful, it will enumerate groups and individual user IDs.

When I try to connect to get it to read Active Directory user containers (it is using port 389 for this) it gives me connection failed, unknown error 0x80005000)  I have port 389 open but perhaps their are others?

Help appreciated.
LVL 1
klmneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Salah Eddine ELMRABETTechnical Lead Manager (Owner)Commented:
Hi,

Have you follwed the how to guide from Video Insight http://www.video-insight.com/support/FAQ/configure-active-directory-for-ipserver.php

I want to ask you if the server hosting Video Insight IP Sever already member of the domain or not? and just figure out that this prerequest is defined in the guide!

So basically you have to join the Video Insight server to the domain, use a domain admin accout to query users and groups.

Regards.

Salah
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
klmneAuthor Commented:
Yes I have followed the guide.  The server is a member of the domain.  I have a service domain account to query with .
0
Salah Eddine ELMRABETTechnical Lead Manager (Owner)Commented:
Hi,

The port you mension 389(also in the guide you can see different port in the screenhsot) isn't LDAP port!! have you change the LDAP configuration on the domain controller??

Try to connect to LDAP using and LDAP tool for Exemple : http://www.ldapadmin.org/ and see if you can have some output, else check if there is any Security policy in the domain controller that prevent connecting to LDAP.

Best Regards.

Salah
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

klmneAuthor Commented:
I connected successfully on 389 with this tool
I am only trying to use 389

Thanks for the tool though.
0
Salah Eddine ELMRABETTechnical Lead Manager (Owner)Commented:
Hi,

Did you find any log in DC events list showing the request from Video Insight server??

Regards.

Salah
0
klmneAuthor Commented:
I have found the problem.  It has to do with using a domain account instead of the servers admin account.  Very frustrating but finally fixed.

Thank you.
0
klmneAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for klmne's comment #a40637468

for the following reason:

I have fixed this by painfully reading each and every line of the fine print of Video Insight's directions.
0
Salah Eddine ELMRABETTechnical Lead Manager (Owner)Commented:
Hi,

I said "So basically you have to join the Video Insight server to the domain, use a domain admin accout to query users and groups." and you answer "Yes I have followed the guide.  The server is a member of the domain.  I have a service domain account to query with"

So I was guiding you, but you didn't pay attention to this.

Regards.
0
klmneAuthor Commented:
I didn't realize that this forum was so hungry for points and credit. I mistakenly thought it was for help..Period.

 I don't really care who gets the credit (I really don't) but it really wasn't something you did or something I did after reading your comments.  You gave me a link to the port tool which was helpful in proving something I already knew worked, but it was a good tool.

Moderator If this re-opens the problem I won't respond anymore.  Just needed my two cents in.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.