mtsc to server 2012 R2 rdp server not working

Hello,
I have an SBS2008 server only DC is in use and added a new proliant  ML350 gen9 server with server 2012 R2 and hyper-v role.
1 Server 2012 R2 guest is joined and is promoted as  a DC,GC with DNS server role.
1 server 2012 R2 guest is joined and has the roles  RD connection broker, RD session host  and RD web access. Self signed certificate hostname.domain.local  is generated.
Computer account is moved to SBS servers OU for now   and windows firewall is disabled.
When I make an rdp connection to the rdp server then I receive a warning from the ssl certificate that it is not trusted (this is normal) when I proceed then the message  This computer can’t connect to the remote computer appears.
An event rd connection broker failed to process the connection request for user element not found is generated.
Do I need to configure the GPO’s or do something else?
Operation masters roles are still on the SBS2008.
Thanks for help!
LVL 1
antwerp2007Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Salah Eddine ELMRABETTechnical Lead Manager (Owner)Commented:
Hi,

When enabling remote desktop, choose accept connection from any host and not from secured host, this will solve the problem.

Regards.

Salah
0
antwerp2007Author Commented:
Hi Salah, thanks for the help.
However i notice that i don't have the session host configuration options in administrative tools.
It seems that rds is not working, when i open the rds deployment task and select add rd session host server the pool is empty. Is this normal when you deploy only 1 rds server or do you need to add it also?
Domain users and terminal server users group are members of the local remote desktop users group on the local rds server.
empty-server-pool.png
rds-installed-roles.png
rds-task.png
running-rds-services.png
administrative-tools.png
0
antwerp2007Author Commented:
Meanwhiile i disbaled the requirement by blocking the AD policy and applying settings below but still the same problem:
On the Remote tab in the System Properties dialog box on an RD Session Host server.

If the Allow connections from computers running any version of Remote Desktop (less secure) is not selected and not enabled, the Require user authentication for remote connections by using Network Level Authentication Group Policy setting has been enabled and has been applied to the RD Session Host server.

To configure the Network Level Authentication setting by using the Remote tab in the System Properties dialog box on an RD Session Host server, see Change Remote Connection Settings.

On the General tab of the Properties dialog box for a connection in the Remote Desktop Session Host Configuration tool by selecting the Allow connections only from computers running Remote Desktop with Network Level Authentication check box.

If the Allow connections only from computers running Remote Desktop with Network Level Authentication check box is selected and is dimmed, the Require user authentication for remote connections by using Network Level Authentication Group Policy setting has been enabled and has been applied to the RD Session Host server.

By applying the Require user authentication for remote connections by using Network Level Authentication Group Policy setting.

This Group Policy setting is located in Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security and can be configured by using either the Local Group Policy Editor or the Group Policy Management Console (GPMC). Note that the Group Policy setting will take precedence over the setting configured in Remote Desktop Session Host Configuration or on the Remote tab.
0
antwerp2007Author Commented:
Recreating twice the session collection in combination with local GPO settings rsolved the issue for me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
antwerp2007Author Commented:
The other solutions has nothing to do with the issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.