Moving wordpress site to another server

Hi,
I'm moving a Wordpress  site to another server. I have full root access to both servers. I am also not changing domain names.
To do the move I have done this:
1.Tarred up the files and moved them to new location.
2. Tarred up the MySql datafiles and moved them to the correct location
3. Changed DNS to point to new server.

When I try to access the site, I can get to the main page http://www.mysite.com and it looks fine,
but if I try to get to any other page using links on the main page - Examples:
www.mysite.com/about
www.mysite.com/contact
or any other page, I get a "The requested URL was not found on this server" message.

Now, I didn't set up this original site, and while I am a programmer, I'm not a Wordpress expert, but I think something called Permalinks were set up -- my links were www.mysite.com/anotherpagehere rather then something more cryptic like www.mysites.com/index.php?term=89
So, I looked up permalinks and people mention the .htaccess file alot. I checked and that file did move across.

My .htaccess file looks like this:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


Do I have to, 'turn on' the .htaccess file in some way?
Or do you think my not being able to get to any other pages is something else?

Thanks!
LVL 1
nachtmskAsked:
Who is Participating?
 
Jason C. LevineNo oneCommented:
There's a different process to move a WordPress site.  I outline it here:

http://www.experts-exchange.com/Web_Development/Blogs/WordPress/A_10258-How-To-Move-A-WordPress-Site.html

However, can you login to the WordPress backend?  If so, go to Settings | Permalinks and turn it back to the default.  Save it, then switch back to your preferred permalinks settings.

That will rebuild the .htaccess and also flush the internal rewrite rules and should fix things.

If you can't login at all, start over and follow the steps I outline in the linked article.
0
 
nachtmskAuthor Commented:
Thanks, Jason.
But I figured it out already. I didn't have mod-rewrite enabled in apache.
I'll give you the points though as your suggestion is also excellent and something I had tried first.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.