Cisco 1532i throughput questions

Hi Experts

Question regarding Cisco 1532i throughput on a 2 site bridge mode connection. With this setup, I am only seeing a maximum of 9to10MB/s file transfer speeds from the remote side to a host on the root side and I think it should be faster.

Here is Root Bridge:
!
! Last configuration change at 04:15:22 -0800 Tue Mar 2 1993
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname root
!
!
logging rate-limit console 9
enable secret 5 $1$7KaA$U/2GxUA8XYnk2gIz1KodA.
!
no aaa new-model
clock timezone -0800 -8 0
no ip source-route
no ip cef
ip name-server 192.168.169.15
!
!
!
!
dot11 syslog
!
dot11 ssid SITE
   authentication open
   authentication key-management wpa version 2
   wpa-psk ascii 7 1238011A43053E310409011A1406371A1313515106
!
!
!
!
crypto pki trustpoint TP-self-signed-3391775252
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3391775252
 revocation-check none
 rsakeypair TP-self-signed-3391775252
!
!
crypto pki certificate chain TP-self-signed-3391775252
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
username CISCO password 7 062506324F41
!
!
bridge irb
!
!
!
interface Dot11Radio0
 no ip address
 shutdown
 antenna gain 0
 speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
 packet retries 64 drop-packet
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
 no ip address
 !
 encryption mode ciphers aes-ccm
 !
 ssid SITE
 !
 antenna gain 0
 peakdetect
 dfs band 3 block
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
 packet retries 64 drop-packet
 channel dfs
 station-role root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface GigabitEthernet1
 no ip address
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 mac-address 1005.ca2a.6214
 ip address 192.168.169.120 255.255.255.0
!
ip default-gateway 192.168.169.2
ip forward-protocol nd
ip http server
ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
 transport input all
!
sntp server time.nist.gov
sntp broadcast client
end

And here is the Non-Root Bridge:
!
! Last configuration change at 15:10:37 -0800 Sat Feb 28 2015
! NVRAM config last updated at 15:10:37 -0800 Sat Feb 28 2015
! NVRAM config last updated at 15:10:37 -0800 Sat Feb 28 2015
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname non-root
!
!
logging rate-limit console 9
enable secret 5 $1$K01k$B1Guw7i0sRO8ba8c8b8hG1
!
no aaa new-model
clock timezone -0800 -8 0
no ip source-route
no ip cef
ip name-server 192.168.169.15
!
!
!
!
dot11 syslog
!
dot11 ssid SITE
   authentication open
   authentication key-management wpa version 2
   wpa-psk ascii 7 15330F0155241911061110103434030A15530B0803
!
!
!
!
!
username CISCO password 7 02250D480809
!
!
bridge irb
!
!
!
interface Dot11Radio0
 no ip address
 shutdown
 antenna gain 0
 packet retries 64 drop-packet
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
 no ip address
 !
 encryption mode ciphers aes-ccm
 !
 ssid SITE
 !
 antenna gain 0
 peakdetect
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
 packet retries 64 drop-packet
 station-role non-root bridge
 bridge-group 1
!
interface GigabitEthernet0
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface GigabitEthernet1
 no ip address
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 mac-address 1005.ca2a.6212
 ip address 192.168.169.220 255.255.255.0
!
ip default-gateway 192.168.169.2
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
 transport input all
!
sntp server time.nist.gov
sntp broadcast client
end

I only have the 5GHz enabled, and I read about turning on the above 40 MHz Channel Width - that option is only on the root bridge ap and not the non-root-bridge - does this equal a problem if turned on the root and not non-root as well?
Will it help?
Should I enable the 2.4 GHz radios as well?

Thanks for looking over the configs.
LVL 1
durango099Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

durango099Author Commented:
In Win8 task manager it is showing 65 to 68 Mbps being sent (on a 100mb switch) and the copy dialog box is showing the 9 to 10MB/s number. Don't know if that helps - both AP's are running the ap1g3-k9w7-tar.153-3.JAB firmware.
0
JustInCaseCommented:
100Mb = 12.5MB.
Usually max transfer speed on 100Mb switch is around 11MB. So, without replacing switch you will not have much speed improvement....
0
Craig BeckCommented:
If you're seeing 65-68Mbps the radio link is working as perfectly as you could expect it to be.

Using 20MHz channel widths the PHY rate (radio link speed) of the bridge link will be 144Mbps (the most it can be).  The formula to calculate throughput is this...

(PHY rate / 2) - 10% = Data throughput in Mbps

We divide the PHY rate by 2 because WiFi is half-duplex.  We then subtract 10% to account for overheads (encryption, etc), so using the formula...

(144 / 2 = 72) - 10% = 64.8Mbps

Convert that to Megabytes..

64.8 / 8 = 8.1MB/s

If you enable 40MHz channel widths (only required at the root) you can double that, so a PHY rate of 300Mbps would be achievable.  Therefore you can expect to see around 135Mbps data throughput.  You'd hit the 100Mbps limit on your switch though.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud as a Security Delivery Platform for MSSPs

Every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. View our on-demand webinar to learn more!

durango099Author Commented:
Ok, I will replace the 10/100 switch with a HP ProCurve 2910al I have for cold spare.

I changed to below and above 40 Mhz on the root bridge and it did not change the transfer speeds - so maybe it is the chump Netgear switch @ my test bench that is the problem.

Will advise after the switch change out

Thanks
0
durango099Author Commented:
So after swapping to the HP 2910al - I am seeing 16.3 MB/sec

Should it be able to reach 35 MB/sec?

Seems odd, the speed doubled from 8 to 16 with the switch change and not higher.

Mark
0
Craig BeckCommented:
The most you'll get is about 16.5MB/s across the link between the radios.
0
durango099Author Commented:
Sending a little love to Predrag Jovic for responding 1st

@craigbeck - Thank you for the assist. I will turn it up for the users and see how they respond as it sounds like it will not get any better.

Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.