We help IT Professionals succeed at work.
Get Started

Nuget Error - Input String was not in a correct format Visual Studio 10

esemmoc
esemmoc asked
on
1,385 Views
Last Modified: 2015-03-03
I am trying to install third party libraries using Nuget (first time user) and am getting an "Input String was not in a correct format" error.  Below is a listing of the error.  Any help would be appreciated.

PM> Install-Package Google.Apis.Oauth2.v2
Attempting to resolve dependency 'Google.Apis (≥ 1.9.0)'.
Attempting to resolve dependency 'Google.Apis.Core (≥ 1.9.0)'.
Attempting to resolve dependency 'Microsoft.Bcl (≥ 1.1.9)'.
Attempting to resolve dependency 'Microsoft.Bcl.Build (≥ 1.0.14)'.
Attempting to resolve dependency 'Microsoft.Bcl.Async (≥ 1.0.168)'.
Attempting to resolve dependency 'Microsoft.Net.Http (≥ 2.2.22)'.
Attempting to resolve dependency 'Newtonsoft.Json (≥ 6.0.4)'.
Attempting to resolve dependency 'log4net (≥ 2.0.3)'.
Attempting to resolve dependency 'Zlib.Portable (≥ 1.10.0)'.
Attempting to resolve dependency 'Google.Apis.Auth (≥ 1.9.0)'.
Installing 'Microsoft.Bcl.Build 1.0.14'.
You are downloading Microsoft.Bcl.Build from Microsoft, the license agreement to which is available at http://go.microsoft.com/fwlink/?LinkId=329770. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Bcl.Build 1.0.14'.
Installing 'Microsoft.Bcl 1.1.9'.
You are downloading Microsoft.Bcl from Microsoft, the license agreement to which is available at http://go.microsoft.com/fwlink/?LinkId=329770. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Bcl 1.1.9'.
Installing 'Microsoft.Bcl.Async 1.0.168'.
You are downloading Microsoft.Bcl.Async from Microsoft, the license agreement to which is available at http://go.microsoft.com/fwlink/?LinkId=329770. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Bcl.Async 1.0.168'.
Installing 'Microsoft.Net.Http 2.2.22'.
You are downloading Microsoft.Net.Http from Microsoft, the license agreement to which is available at http://go.microsoft.com/fwlink/?LinkId=329770. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Net.Http 2.2.22'.
Installing 'Newtonsoft.Json 6.0.4'.
Successfully installed 'Newtonsoft.Json 6.0.4'.
Installing 'Google.Apis.Core 1.9.0'.
Successfully installed 'Google.Apis.Core 1.9.0'.
Installing 'log4net 2.0.3'.
Successfully installed 'log4net 2.0.3'.
Installing 'Zlib.Portable 1.10.0'.
You are downloading Zlib.Portable from AdvancedREI,  onovotny, the license agreement to which is available at http://en.wikipedia.org/wiki/Zlib_License. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Zlib.Portable 1.10.0'.
Installing 'Google.Apis 1.9.0'.
Successfully installed 'Google.Apis 1.9.0'.
Installing 'Google.Apis.Auth 1.9.0'.
Successfully installed 'Google.Apis.Auth 1.9.0'.
Installing 'Google.Apis.Oauth2.v2 1.9.0.860'.
Successfully installed 'Google.Apis.Oauth2.v2 1.9.0.860'.
Adding 'Microsoft.Bcl.Build 1.0.14' to gcal2.
Successfully added 'Microsoft.Bcl.Build 1.0.14' to gcal2.
Adding 'Microsoft.Bcl 1.1.9' to gcal2.
Install failed. Rolling back...
Install-Package : Input string was not in a correct format.
At line:1 char:16
+ Install-Package <<<<  Google.Apis.Oauth2.v2
    + CategoryInfo          : NotSpecified: (:) [Install-Package], FormatException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
Comment
Watch Question
The More I know, the more I don't know
CERTIFIED EXPERT
Distinguished Expert 2020
Commented:
This problem has been solved!
Unlock 1 Answer and 1 Comment.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE