public folder: add permission to a security group

hello,

i have public folder on exchange 2013.

i need to add permission for one security group to a specific public folder, but its not work with this command:

Add-PublicFolderClientPermission -Identity "\publicfoldername" -user "securitygroup" -AccessRights author

and i have this error:

The user "securitygroup" is either not valid SMTP address, or there is no matching information.

any solution plz?

thanks
cawasakiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Miguel Angel Perez MuñozCommented:
You can not use a group to give permissions on public folders, must be done user per user.
0
Miguel Angel Perez MuñozCommented:
Plus, can try adding using AddUsersToPFRecursive.ps1 script, to add users contained on a group. But changing group members causes public folders permissions not be refreshed: http://khurramullah.blogspot.com.es/2009/04/powershell-command-for-public-folder_30.html
0
Spike99On-Site IT TechnicianCommented:
Is that group a distribution list with a valid SMTP address?   If it is, I think you need to use the Exchange alias for the group and not the actual group name (if they differ).
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

cawasakiAuthor Commented:
hello miguel

no i can use group sorry, all my public folder are with group permission, but group with mail enabled
0
Will SzymkowskiSenior Solution ArchitectCommented:
You can use Mail-Enabled Security Groups to assign permissions to public folders. See screenshot below.
secperm.JPG
and i have this error:

The user "securitygroup" is either not valid SMTP address, or there is no matching information

Also based on the error above you are probbaly not using a "Universal Mail-Enabled Security Group" which is why you are getting the error message. I have a screenshot of the test group from Active Directory.
secperm2.JPG
Once you have the proper group it will work for you. If you want to use the same group you will need to change it to Universal and Mail-Enabled.

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cawasakiAuthor Commented:
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.