exchange 2010 hub cas server cant access OWA or ECP websites

I am working on an exchange server setup for a dev lab environment. The setup is fairly simple 1 mbx server and 1 hub/cas server. So far on the cas server I have installed IIS and the exchange hub/cas prereqs and software. At this point exchange has been installed and to me looks good.

I can open IIS and see the exchange websites listed. However if I right click on the any of the sites and attempt to browse I get a page can not be displayed error.

For exampe OWA, I have tested with
Localhost/owa
servername/owa
ipaddress/owa

All with no luck.



I have confirmed that the OWAvirtualdirectory is set correctly, the ECP virtual directory is set correctly, and the webservices virtual directory are set to the correct values.

Any help in troubleshooting this issue would be appreciated.

Thanks
LVL 35
Joseph DalyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
In a browser, if you go to https://localhost/ 
what happens?
If that works, what happens if you use https://localhost/owa 

If neither work, then it is probably the SSL certificate is corrupt.
See if you can start EMS and then run new-exchangecertificate

Unless you are replicating a live environment, you are wasting your time with separate CAS/Hub. That is no longer considered best practise.

Simon.
Joseph DalyAuthor Commented:
We are not using HTTPS on this enviroment. It is only a dev environment so if I got to http://localhost i get the IIS page. If I go to HTTP://localhost/owa I get a page can not be found message. Same thing with HTTP://localhost/ECP

We do have hub/cas on the same server.
Will SzymkowskiSenior Solution ArchitectCommented:
Have you checked the IIS services to ensure that they are started? Also ensure that all of the Exchange Services have started as well. If you reboot the server do you get the same results after it comes back online? If this is a net new install then it should work out-of the-box using localhost. That's why i am referencing the services.

If you go to https://localhost/owa 
You should get a cert error and then say "continue to this website" which will then proceed.

If you are only using http://localhost/owa that OWA directory is setup to "Require SSL" but "ignore client certificates". These are the default settings. If you check the SSL Settings for that site you will see this is why i cannot connect to http. But rather using https and continue to proceed without a certificate.

Will.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Joseph DalyAuthor Commented:
I have rebooted this server several times and that has not resovled the issue. Confirming what you requested on the services for IIS and exchange, All Microsoft Exchange services are set to automatic and currently started. The WWW publishing service and the IIS admin services are both set to automatic and currently running.

Its the strangest thing because I can not even browse to the site through the IIS management console.
Will SzymkowskiSenior Solution ArchitectCommented:
Did you try my suggestion above using https and then clicking the link "continue to this website"? SSL is required on the OWA directory by default that is why it is throwing an error. Using SSL is by default.

If you want to strictly only use HTTP you need to go to the SSL settings for the OWA directory and remove SSL. See screenshots below...
sss1.JPGssss2.JPGsss3.JPGsss4.JPGWill.
Simon Butler (Sembee)ConsultantCommented:
If you aren't even getting the SSL prompt when you use localhost, that is classic corrupt SSL certificate. Not unusual unfortunately.

Simon.
Joseph DalyAuthor Commented:
So I have disabled the require SSL box on the owa site and unfortuntately I am still not seeing anything whatsoever.


IIS
IE
Sembee: How would I go about checking the corrupt SSL? Im willing to take a look even if we arent using it.
Will SzymkowskiSenior Solution ArchitectCommented:
If you are not using SSL then it is not a cert issue. Make sure that your Default Web Site is Started. When I stop my default website i get the same message as you do. When i start it, the site works fine.

ssl.JPG
Also if all of your services are started starting looking in logs for more details.

Will.
Joseph DalyAuthor Commented:
Default website is started and I can browse to it from the console. Get the IIS setup page.

The only errors im seeing are in the application log and are from 5 days ago and they state.

"Webhost failed to process a request system.servicemodel.servicehostingenvironment. The service /EWS/exchange.asmx
cannot be activated due to an exception during compilation"

This error message appears about every 30 seconds but I have not seen that logged in several days.
Will SzymkowskiSenior Solution ArchitectCommented:
Can you access any other virtual directory or are they all getting the same result? If you are using http:// make sure you disable SSL first before proceeding. If you are using SSL does the page load to where you have to Continue to Proceed warning?

Will.
Joseph DalyAuthor Commented:
I receive similar page not displayed error messages for OWA/ECP.

If i try to connect to powershell or autodiscover I get prompted for a username and password.

If I try to connect to EWS I get a 403 Forbidden message.

If I try accessing those same directories using HTTPS i do not get ay type of warning or continue message. I immediately get a page can not be found error.
Will SzymkowskiSenior Solution ArchitectCommented:
If you have ensure the following...
- Exchange services are running
- IIS (Windows Services) are running
- Default Website is running
- Disable SSL on the site

You might want to reset the virtual directories. See the below Technet to proceed.
https://technet.microsoft.com/en-us/library/ff629372%28v=exchg.141%29.aspx

Will.
Joseph DalyAuthor Commented:
So just as a quick test I reset the OWA virtual directory using the steps that they provided. And even with the directory reset back to default I am still unable to access this site. Something is definitley messed up here.
Joseph DalyAuthor Commented:
Ive read online that an uninstall of both exchange and IIS will return the server back to a good starting postion where I can then reinstall everything using MS defaults and test.

What do you guys think about this?
Will SzymkowskiSenior Solution ArchitectCommented:
You may want to bring up a new server and reinstall Exchange on it and ensure that everything is working correctly. There seems to be a more systemic issue on your Exchange server other then the IIS not working properly. As i have illustrated you can do what you are asking for very easily (screenshots provided) but something else is definitely not right.

Will.
Joseph DalyAuthor Commented:
Normally I would agree with you on the new server but this is in a non connected lab environment and spinning up a new server can be a lot of work i.e. phone activation with MS offline patching etc.

I think I am going to try to rever the existing server to as clean of a state as I can get it and then retry exchange/IIs. If I still have no luck I will blow it away and start fresh :(
Will SzymkowskiSenior Solution ArchitectCommented:
Unfortunately the IIS should work out of the box, unless you have go in and made unnecessary changes where it no longer works.

If this is just a lab environment it should be pretty quick to spin up another machine just to test that this will work by default after you install Exchange successfully.

Will.
Joseph DalyAuthor Commented:
I did the uninstall and reinstall iis and exchange hub/cas roles. At this point things look much better with the exchange install. I can now reach both owa and ecp using the browse option in IIS,

One strange thing and im sure its probably an IIS setting I am missing but I can connect to
127.0.0.1/owa but not localhost/owa

I think this has something to do with the default websites binding options but im not 100% sure.
Will SzymkowskiSenior Solution ArchitectCommented:
Well that's good, that it is working now. Something was definitely wrong with the other installation. Can you ping localhost?

Will.
Joseph DalyAuthor Commented:
I'll have to get back to you tomorrow
Joseph DalyAuthor Commented:
Something was defintiely messed up with the exchange installation, I ended up uninstalling both exchange and IIS on the server reverting it back to as clean of a state as possible. At that point I went through and confirmed pre-reqs and began a reinstallation of exchange and IIS.

I would agree that in a real environment the best course of action would be to completely blow away the servers and start fresh with brand new servers.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Will SzymkowskiSenior Solution ArchitectCommented:
Glad that new servers confirmed this. IIS works out of the box after installing Exchange as stated before. Make sure that you do no mess with the IIS settings as you can break Exchange as you have experienced.

Will.
Joseph DalyAuthor Commented:
My solution only adds more information to the problem so that the resolution and steps i  took to get there was clear to anyone else searching.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.