How can I force Microsoft Windows 7 from going into hibernation?

My Windows 7 Professional machine goes into hibernation when I am away from the device for over 40 minutes. This interrupts batch programs that I run -- some of them requiring six hours.

Microsoft recommends as administrator giving the DOS command "powercfg.exe /hibernate off" in the root directory of the volume containing Windows. Very nice, but it doesn't work.

How can I get the machine to stay awake until it finishes intense batch jobs?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
See if the Microsoft FixIt for hibernation helps you.

You can also try deleting the hidden file hiberfil.sys in the root directory.

Try the FixIt first.
JohnBusiness Consultant (Owner)Commented:
You can also lengthen the time to hibernation to 3 hours or more.
Lee W, MVPTechnology and Business Process AdvisorCommented:
Set Sleep and Hibernation times to 0.  That should disable them.  These settings are in the Power Options Control Panel.  Click on the hyperlink to "Change plan settings" then click on Change advanced power settings.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

You must run cmd as admin.

Turn off hibernation  
powercfg -h off
Set standby to infinite (0) according to power source
powercfg -change -standby-timeout-ac 0
powercfg -change -standby-timeout-dc 0

This gives the same result as suggestion from Lee W. I guess that in your case, after you issued turning off hibernation (it works :) computer was still going to sleep.
You say "powercfg.exe /hibernate off" doesn't work. In what way doesn't it work? Do you get any error message when executing that command? Might there be a policy set that doesn't allow things like that to be changed?
StMike38Author Commented:
JohnBusiness Consultant (Owner)Commented:
@StMike38 - You are very welcome and I was happy to help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.