Cannot add machines to Vcentre appliance

OK I have 2 sites A & B
Site A has 6 ESX 5.1 hosts
Site A has 4 ESX 5.1 hosts
Currently all are managed by a Windows VCentre 5.1 on Site A
No issues, except the server itself is heavily loaded and vcentre is sluggish

So installed VCentre 5,5 appliance at site A
Works fine, SSO & AD integration. Grand no problem.

I then tested adding a host from site A to appliance.
Seemed to be OK, except that it's part of an HA cluster and that would fail etc.
So didnt add, but seems that it will.

But when it comes to adding hosts from site B to the appliance I get an error

"Call "Datacenter.QueryConnectionInfo" for object "Cluster" on vCenter Server "appliance" failed."

So Googling says check DNS, check adding by FQDN, check network management agents, check password

None of it makes any difference.

Using VSphere client at site B I can connect to hosts on Site A & B
Using VSphere client at site A I can connect to hosts on Site A & B

Virtual appliance usable from Site A & B
Virtual appliance can ping hosts on sites A & B

It's not password, it's not lockdown.
Reboot management network, or host makes no difference.
Connectivity doesn't appear to be the issue however when I do try
to add a host from Site B, it doesn't bother prompting be or the SHA thumbprint

It does for the servers on Site A.

One interesting thing  mentioned here

Disabling IP6.

Not sure how to do that
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
For information your Windows vCenter should have at least 16GB and 4 vCPU and a separate SQL Db.

Anyway your issue looks like a DNS network resolution issue.

IP6 can be disabled on console under network management or on the management vSwitch.

Check DNS for all ESXi hosts
MajicthiseAuthor Commented:
It has 2 cpu and was told that was enough - this patently is not the case.
So I'm happy to move to the appliance

DNS is fine on all hosts.
If it wasn't would I not have issues with existing vcentre?
And if it was DNS wouldn't I stillbe able to add by IP?
MajicthiseAuthor Commented:
The existing Vcentre on Site A can connect by IP or name to servers on Site B

The new appliance cannot
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Check all hosts and appliance.

And then check all your DNS server entries for hosts and appliance.

Did you login to appliance and ping and trace route hostnames for hosts?

I would also update ESXi 5.1 to latest version as you have switched vcentet version.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Is the default gateway correct on appliance
MajicthiseAuthor Commented:
I will update VCentre to 5.5 but as they are not yet managed by 5.5 VCentre I cannot upgrade them.
I would like to migrate to 5.5 Appliance as 5.1hosts and confirm everything is fine then upgrade hosts to 5.5

Appliance gateway is correct or at least correctly listed in gui
I can also access it from Site B - bad gateway would mean could only access it from Site A (I think)
It can ping Site A & B machines by ip and fqdn. Nslookup reports from correct server with correct data

traceroute is fine for local, but pretty sure the firewall isn't allowing the packets thru
MajicthiseAuthor Commented:
I also can add either of the Site B hosts by either IP or name to the existing VCentre server on site A
So It doesn't appear to be the hosts issue.

It's as if the virtual appliance cannot get of the site
But it can ping and be controlled by a machine on site a
Bother the web client and the Vcentre client and the config page.

It's driving me crackers
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
And logged into appliance you have confirmed connevtivity

Do you have a firewall or routing?

Have you tried the IP address of vcenter for windows on appliance
MajicthiseAuthor Commented:
Yes there is a firewall
I can log onto the console sessions of the appliance and ping the hosts o nboth sites by name or IP

I'm not sure I understand the last sentence though?
I can ping the existing vcentre by name or fqdn also. Is that what you're asking?

I dont know if it's significant but I cannot ping any machine from the appliance if i use machine name only
eg I have to specify domain?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Remove all hosts from vcenter 5.1

Shutdown and turn off 5.1 vcenter

Give the appliance the IP address of old vcenter server
MajicthiseAuthor Commented:
I'm not ready to do that yet. I need to know it works before I move them off VCentre 5.1

The servers on site A warn me that moving them from the VCentre to the appliance will break the cluster HA
But I get nothing at all when trying the servers on Site B

Besides I cannot shut down the VCEnrte server it's handling SQL for other stuff, so it's not an option.

What I did was remove one site B server from the existing vcentre server. I put it in maintenance mode, disconnected it, then removed from inventory

I then attempted to add it to the new VCentre appliance and it failed straight away. Same error. No thumprint check nothing

So I then tried to reconnect it back to my existing VCentre and it worked like it ought to.  Came in as in maintenance mode, brought it out of maintenance and no problem at all.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
So maybe your IP address of appliance is being blocked!
MajicthiseAuthor Commented:
By what though? The host?
The appliance can ping the host by name & IP and just about everything else
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Ping is not a method of check for data transfer!

Ping does not communicate the same way as vCenter via 443 and the other ports required for access.

Some communication is down or blocked between appliance and host.

The answer will be in the vcenter logs or escalate to VMware Support.

Have you looked in the logs.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MajicthiseAuthor Commented:
Yes but it's a minefield to me.

U reckon VMWare will assist?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
That's what a VMware Support contract is for!

Must go to bed early flight in an!
MajicthiseAuthor Commented:
Thanks for prodding my brain.
Firewall rule existed for OLD vcentre only.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.