SQL server 2012 services are not starting automatically with Windows 2012 boot

We have a cluster of SQL servers (Windows 2012) on one node the SQL services will not start at boot time.  Any ideas?  This is a virtualized environment on VMware ESXi 5.5 platform.
LVL 4
Harper McDonaldAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Does it start manually after boot eg after 19 mins

If so have you tried a delayed start?

Also this is a sign of poor performance if so increase vCPUs Memory

Also what is data store hosted on?
Harper McDonaldAuthor Commented:
It does not start only if you manually start the service (and it actually does sometime work if you re-enter the password - but only for a couple of reboots...weird)  I have not tried delayed start, we would need this to be automatic but I will give it a shot.  We have increased memory and it was working fine (12 GB - should be plenty) Data Store is on a Netapp SAN.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Auto Start with delay....

Eg starts the OS waits and then starts SQL.

Use Jumbo Frames

Increase vCPU
Need More Insight Into What’s Killing Your Network

Flow data analysis from SolarWinds NetFlow Traffic Analyzer (NTA), along with Network Performance Monitor (NPM), can give you deeper visibility into your network’s traffic.

Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
I don't have the answer (far more likely Andrew will ultimately root out the cause), but just tossing out a thought -- You mention that this is a cluster, with one node.  That says to me that the service should be managed/controlled through the Failover Cluster Manager, not through services like any other SQL server might be managed.  Just confirming... you aren't starting/stopping the SQL server thru the services applet are you?
Harper McDonaldAuthor Commented:
It's a 4 node cluster - not through the services but through the SQL config manager...
Harper McDonaldAuthor Commented:
Removed vNIC from VM, uninstalled VMware tools, rebooted, added new vNIC, reinstalled VMware tools, re-ip'ed, rebooted -- services started normally.  Thinking a corrupt TCP/IP stack.  Issue resolved.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Harper McDonaldAuthor Commented:
This solution fixed my issue.
Harper McDonaldAuthor Commented:
This solution fixed my issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.