Computer returning wrong dns address when pinged

pinging my laptop  from my workstation using its windows name returns a dns of 66.115.130.138. I dont know what that address is for. If i ping any word from the workstation I get the same result. Even tried pinging the word crap, got a reply from 66.115.130.138.

Internet and network working fine except for a rendering program (vray) which uses other computers on the network to render images. Need this program to work.
george chianeseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don S.Commented:
It simply means that the DNS you are pointing to can't resolve the simple name your are pinging.  If you ping a FQDN, then you will get the usual can't resolve message.
0
JohnBusiness Consultant (Owner)Commented:
On the problem machine, run TCP/IP Reset and DNS Flush.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

See if that helps.
0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
pinging my laptop  from my workstation using its windows name returns a dns of 66.115.130.138. doesn't make sense. Unless you use NsLookup you never see which DNS server is asked.

Are you trying to say that the returned IP address is 66.115.130.138 all the time? In that case the public DNS server is asked, and it might just return your single public IP for unknown names being part of your DNS domain (as hinted in http:#a0642634).

For internal DNS to be working well you need a local DNS server, and it should be the default DNS server used for all machines.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

george chianeseAuthor Commented:
Tried John's suggestions. And yes the returned IP address is now 66.115.130.139. Still wrong.
This is just a simple win7 home network with a verizon router MI424WR and a TPLINK gigabit switch.
0
Seth SimmonsSr. Systems AdministratorCommented:
add an entry to your hosts file (\windows\system32\drivers\etc)
edit the file elevated (run notepad as administrator)
add an entry at the end
if your system is named foo with an address of 192.168.1.10 then put at the end of the file:

192.168.1.10 foo

save it then try to ping it again
0
JohnBusiness Consultant (Owner)Commented:
Please do an IPCONFIG /ALL from command prompt on both machines and post the output here. Are you on the same subnet on both machines?  Are both machines on the same WORKGROUP?

Something seems strange.
0
giltjrCommented:
Can you give us a screen shot of exactly what you enter and exactly what you get back.

This is in-addition to the ipconfig /all that John Hurst requested.

My guess is you are ping'ing a name that does not have a valid DNS entry and the DNS server you are configured to use is setup to return a specific fixed IP address to for any lookups that are not valid.
0
george chianeseAuthor Commented:
Here are the results of both.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\users\georgec>ping lenovo

Pinging lenovo.home [66.115.130.139] with 32 bytes of data:
Reply from 66.115.130.139: bytes=32 time=24ms TTL=56
Reply from 66.115.130.139: bytes=32 time=27ms TTL=56
Reply from 66.115.130.139: bytes=32 time=26ms TTL=56
Reply from 66.115.130.139: bytes=32 time=24ms TTL=56

Ping statistics for 66.115.130.139:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 24ms, Maximum = 27ms, Average = 25ms

C:\users\georgec>

C:\users\georgec>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : hpxw6600
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : home

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 00-1F-29-01-42-7E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::bd39:ca24:81b4:cee%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.5(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Tuesday, March 03, 2015 1:32:03 PM
   Lease Expires . . . . . . . . . . : Wednesday, March 04, 2015 1:32:02 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 318775081
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-FD-76-D5-00-1F-29-01-42-7E

   DNS Servers . . . . . . . . . . . : 151.196.0.37
                                       151.197.0.37
   NetBIOS over Tcpip. . . . . . . . : Enabled
0
JohnBusiness Consultant (Owner)Commented:
You are trying to ping an internal network from an outside network. That generally will not work without a VPN connection.
0
giltjrCommented:
Yep  " lenovo.home" is not valid on the public Internet.  The DNS server is doing what I said, it has no clue about "levono.home" so it returns a fixed IP address of 66.115.130.139.

If you want to ping by host name for non-public names, you need to either setup your own DNS server or setup  entries in your hosts file as Seth Simmons suggested.
0
george chianeseAuthor Commented:
John, I dont know how that is happening. These computers are all on the same network, same workgroup. Is this a firewall issue? I am using Commodo on all.
0
JohnBusiness Consultant (Owner)Commented:
If that is true. why does the machine have an external IP address for its active connection?  Are you connecting by cellular card?
0
george chianeseAuthor Commented:
Tried Seth's suggestion. Ping now returns correct address.
0
george chianeseAuthor Commented:
I have no idea. Connecting through ethernet network card. No other connections on that machine, not even wireless. I did use the log me in program a while back, could that have changed anything?
0
JohnBusiness Consultant (Owner)Commented:
Did you flush DNS?
0
giltjrCommented:
Other than their own IP address all of the network settings would need to be the same.  For them to get the same results.

Depending on how many computers you have, you may want to setup your own DNS server.  It would probably be easier than maintaining the hosts file on multiple computers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
george chianeseAuthor Commented:
Thanks, I'll look into that.
0
george chianeseAuthor Commented:
I looked at the  ipv4 settings of the network card. It had a manual entry for the dns server. Changed it back to automatic. Seems to be working now without having to change the hosts file.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.