We help IT Professionals succeed at work.

Outlook Web App error for new user

holtzer
holtzer asked
on
Hello,

Recently, our new  user can't get on OWA because their regional setting page is returning "An unexpected error occurred and your request couldn't be handled."

with "Url: https://mail.shdm.org:443/owa/languageselection.aspx

I've search many site and i've not been able to find a working solution.

I've check the redirection, everything seems ok

here is the complete detail message

	An unexpected error occurred and your request couldn't be handled.


Request
Url: https://mail.shdm.org:443/owa/languageselection.aspx
User: promoteurs@shdm.org
EX Address: /o=SHDM/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=promoteurs790
SMTP Address: promoteurs@shdm.org
OWA version: 14.3.195.1

Exception
Exception type: System.ArgumentNullException
Exception message: Value cannot be null. Parameter name: value

Call stack
Microsoft.Exchange.Clients.Owa.Core.Utilities.RenderDirectionEnhancedValue(TextWriter output, String value, Boolean isRtl)
Microsoft.Exchange.Clients.Owa.Core.LanguageSelection.RenderTimeZoneSelection()
ASP.languageselection_aspx.__Render__control1(HtmlTextWriter __w, Control parameterContainer)
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
System.Web.UI.Page.Render(HtmlTextWriter writer)
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Open in new window


Hope that someone can help!
Alexandre
Comment
Watch Question

Most Valuable Expert 2014
Commented:
If you run

get-mailbox username | select identity, languages

what does it return? If it isn't valid, then you can change it.

set-mailbox username -language 1033

(1033 is US English).

Simon.

Author

Commented:
Hello Simon,

I appreciate the cmdlet you gave me, it actually helped me set the language back to $null and then i can make more test (no longer need to create a new box for testing purposes)

I was using my user to set the problematic user regional setting in the ECP, was working good as a working around  but what would it take to fix it and let user choose their language by themself.

Alexandre
Most Valuable Expert 2014

Commented:
Set the language code to 0 (not null). That should give you the page again.

Simon.
Commented:
Hello Simon,

Sorry for the delay, after some reading and some posting (i posted the same on technet to be sure) and someone there suggested that i update the server with the latest SP3 CU8 (i was on CU6) and it fixed the problem.

Though i appreciate your help

Author

Commented:
I found the solution but Simon helped me with pointers and cmdlet