Web browsing via iPad and iPhone devices through SQUID Proxy

We are having trouble enabling users to browse the internet from iPad and iPhone devices.
 
We use SQUID Proxy for MessageLabs in our environment and whilst all desktop and laptop devices are working fine through SQUID Proxy via WPAD file in DHCP. Unfortunately, we have had no success in accessing the internet using an iPad or iPhone device.
 
Has anyone had any success in enabling web traffic on iPad or iPhone devices through internet proxy? Ideally, we would like to automate this when a user logs on to the network and no manual proxy addresses to be added. I thought this could be achieved via DHCP or DNS but on these devices it is not working.
 
Please help
LVL 1
the_omnificAsked:
Who is Participating?
 
the_omnificAuthor Commented:
This was resolved by adding the following code into my SQUID config file;

acl iOS_Range src 10.10.22.0/24 10.10.6.0/24
http_access allow iOS_Range
0
 
Mark BullockQA Engineer IIICommented:
You can configure manually in Settings / WiFi / tap your wifi network, then

tap HTTP PROXY=Manual and enter the info for your proxy.

Or tap HTTP PROXY=Auto and enter the URL of a PAC file you create and host internally.

Or you can deploy to lots of users as mentioned on this page.
http://www.amsys.co.uk/2012/blog/how-to-setup-proxy-servers-in-ios/#.VPaiV7PF9WU

Apple's iOS Deployment Reference also has instructions. Chapter 2 helps you figure out how you should handle your deployment (e.g. company-owned, Bring Your Own Device, or ...).
0
 
the_omnificAuthor Commented:
Hi Mark
 
I want to avoid manually entering proxy information as per my original request. Providing this information to staff and guests is not practical.
 
I need a solution that would automatically detect proxy settings without any user input on these devices.
 
I will search around more and see what I can find.
0
 
Mark BullockQA Engineer IIICommented:
I forgot to include the link to Apple's iOS Deployment reference.
https://manuals.info.apple.com/MANUALS/1000/MA1685/en_US/ios_deployment_reference.pdf
0
 
the_omnificAuthor Commented:
This was resolved by adding the following code into my SQUID config file;

acl iOS_Range src 10.10.22.0/24 10.10.6.0/24
http_access allow iOS_Range
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.