We help IT Professionals succeed at work.

Staged Exchange Migration Office 365

clickamik
clickamik asked
on
Hello :

I am running Stage Exchange Migration to Office 365 from our local Exchange 2007 Server.

We have migrated one user mailbox to test migration process and all seems to be OK. Mails, Contacts and Agenda are now migrated to Exchange Online mailbox.

The problem is that external mails are not redirecting to Exchange Online mailbox but internals mails (from users in Exchange 2007 Server) are well redirected.

Running Microsoft Exchange Trouble Assistant from our Exchange 2007 Server we verify that external mail is delivered to internal mailbox but acceding from OWA to the internal mailbox no mail is delivered to the internal mailbox (this should be correct).

But after verifying Exchange Online mailbox  the external mail is not delivered. We have verified that external mail is  not classified as a SPAM in Junk Email Folder.

Anyone knows what could be going wrong?
Comment
Watch Question

Most Valuable Expert 2015
Distinguished Expert 2019

Commented:
After the migration, you should convert the mailbox for that user to mail-enabled user. Other than that, verify that the correct target address is populated for the mailbox, should be user@tenant.onmicrosoft.com. Lastly, run a trace to see if the message ever left the local Exchange/ever reached the EO server.

Author

Commented:
Hi Vasil:

.- Mail useris enabled in EO Serve.
.- Address is populated (as secondary adress)
-. I tried to run trace from Microsoft Exchange and I verified that external mail are not reached Eo Server.
-. This is an trace for internal mail:
       1. EventID RESOLVE | Source ROUTING
       2. EventID TRANSFER | Source ROUTING
       3. EventID SEND | Source SMTP
-. This is trace for external mail:
      1.- EventID RESOLVE | Source ROUTING

It seems that external mail is not been redirected to EO Server.

Why?
Most Valuable Expert 2015
Distinguished Expert 2019
Commented:
The onmicrosoft.com alias needs to be added as targetaddress, not secondary alias.