CA Server not issueing certificates

Migrated CA from old 2008 DC to new 2012 R2 DC and certificates are not being issued.  Auto enrollment setup but Templates are unavailable.  Added rights to Public Key Services and no difference.  Now one of the DC's certificate's has expired and it is not being issued a new one.  Not sure what to do at this point.  Should I just rebuild a new one not on a DC and go from there?
HPCWCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LukeMoCommented:
Many things could have occurred here.

Did you only have one issuing CA?    
If the templates aren't available, can you recreate them?
Any pending certs?

Was that CA's cert self signed or does it chain up ?
0
HPCWCAuthor Commented:
Only one issuing CA.
Unable to create new templates...option is greyed out.
No pending certs.

Not sure how to check if it was self signed or not.

When I migrated the CA to the new server it kept the old CA name - gj-oldeserver-CA.  Now being listed on a new server how should the server be listed under certutil?
0
HPCWCAuthor Commented:
More information..When I try to auto-enroll it comes up saying that "Certificate types are not available".  If I check the Show All Templates box at the bottom, all of the templates show up but are listed with a red X "Status: Unavailable".  Thanks for any help anyone can provide!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

LukeMoCommented:
Create new templates, use new names for them.  

I've not repaired the issue you've got, but I have worked around it.  

I tried several things then I installed a new Root/standalone CA, then added a new enterprise CA to my 2012R2 domain.  

If you're dealing with a self-signed root/issuing CA, then you have it a little easier.
You'll need to add your root CA as a trusted root to your clients.  That's done in powershell from a domain controller.  

This guide here is pretty thorough and can be used to stand up a completely new 2-Tier PKI and then add your domain machines to it.    

http://www.derekseaman.com/2014/01/windows-server-2012-r2-two-tier-pki-ca-pt-3.html

If you're dealing with outside machines authenticating to your corporate resources, you'll need to use an external/trusted CA as your root.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HPCWCAuthor Commented:
Rebuilt the CA on a stand alone VM and removed it from the DC and everything is now working.  Thanks for your help with this!  Have a great day!
0
HPCWCAuthor Commented:
Thanks for your help!  Don't build a CA on a DC.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.