We help IT Professionals succeed at work.

ESXi not coming up after port trunking.

Hi All,

Initially my host was running fine, Configured data store But After trunking ports the host is not coming up and showing request timed out,
Kindly assist.
Comment
Watch Question

RafaelArchitect - Network Engineer - Instructor

Commented:
You configured trunking but what is the other side configured for ? If it is not matching on both sides it will not work properly.
Techie solutionVMware Specialist

Author

Commented:
What do you mean by other side?
Top Expert 2014

Commented:
Did you rebooted your host after trunking?

Are you able to access the console of your host? (by iLO / DRAC) or do you have physical access to the box?

What version of ESXi you are running, Hardware model?
Top Expert 2015

Commented:
Remove all but one trunked connections. It should fail over to swhere you were before (provided you configured at least one management network adapter before trunking)
Techie solutionVMware Specialist

Author

Commented:
Yes I rebooted the host, and able to see the console through ILO.
It is 5.1, ProLiant DL580 G5.
Top Expert 2015

Commented:
Will not help.
You need to remove all but one trunked cables, so all trunk protocol mismatches with switch disappear.
Techie solutionVMware Specialist

Author

Commented:
Hi All,

Can I try "switchport nonegotiate " on Trunking?
Is there any harm in this.
Top Expert 2014

Commented:
By the other side they mean the switch ports you are connected to.  Both "sides", ESXi and the switch, must be configured for trunking.
Techie solutionVMware Specialist

Author

Commented:
It is configured for trunking but can I add this too (switchport nonegotiate ) to my configuration on Cisco switches.

I saw a vmware kb article and they are suggesting to do so but I dont know the fact so I am not proceeding with this.
Top Expert 2014

Commented:
O.K. "Trunking" in this instance is something different that what I think gheist is talking about.

Are you allowing only specific VLAN's over the link? Or are you allowing all VLAN's?  Are you using VLAN 1 as the native VLAN?

 Can you post the config of the port on the Cisco switch?
Top Expert 2014
Commented:
Techie solutionVMware Specialist

Author

Commented:
Yes, this is the article I was talking about.
Top Expert 2015

Commented:
To regain connectivity you need to unplug cables. (or shutdown surplus ports on the switch)
Top Expert 2014
Commented:
@gheist - I think in this situation the term "trunking" is Cisco mode of trunking, which means using VLAN tagged frames.  It's not combining two or more connections so they logically appear as a single connection (LACP/LAG, or Cisco Etherchannel)  which is what most other venders call trunking.
Top Expert 2015

Commented:
I know... But then again why connectivity is lost completely?
Top Expert 2014

Commented:
@gheist. My initial assumption is that he does not have correct VLAN's coded, but you know he has not said if he has multiiple NIC's or not.  So you may have a point, if one is configured for tagged VLAN's and one is not that could cause a problem.

@Techie solution:

1) Do you have more than one NIC on your ESXi host?
2) Did you configure both NIC's for trunking?
3) Did you configure both switch ports for trunking?
4) Do you have the NIC's in a NIC team/bonded.
5) Are both NIC's connected to the same switch or are the connected to different switches.
6) When you say "the host is not coming up", are you talking about the ESXi host or 1 or more indvidual VMs?
7) On the switch side have you allow all VLAN's that you need?  Can you post the config for the switch?
8) On the ESXi side is all traffic going over the same NIC/NIC's?  Meaning is guest, service console, and vmkernel going over a single NIC group of NIC's?  Or are you physically separating different types of traffic over different physical NICs?
Techie solutionVMware Specialist

Author

Commented:
Hi all, thank you!

I have 8 nice configured in my host. All our trunked except the two Which is for vmotion and management network.

Now my host is working fine and I disabled DTP on nic0 and nic1.
It is working fine.