Windows Server 2008 PHP

I have a website that I have installed on a Windows Server 2008.  The pages are in PHP.  I have loaded an html file and it shows fine, but when I go to the PHP index, there is an empty page.  Is there a setting that needs to be made so that a PHP shows?  PHP is installed on the server.  Can anyone give me a suggestion on where to start?
LVL 8
rgranlundAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian TaoSenior Business Solutions ConsultantCommented:
Maybe there's something wrong with your php index page.  Can you create a hello.php that has the code:
<?php
echo "hello world";
?>

Open in new window

Navigate to the page in your browser and see if it works?
0
Ray PaseurCommented:
Check your php.ini and make sure these settings are correct:

display_errors = On
log_errors = On
log_errors_max_len = 1024
error_log = error_log

I don't know anybody who uses Windows for a PHP server, so I can't help with that part, but those settings are copy/paste from my php.ini

HTH, ~Ray
0
gr8gonzoConsultantCommented:
What's the web server you're using? Apache? IIS?

To be honest, I would just suggest using the EasyPHP setup (www.easyphp.org). It's fairly simple to install and takes care of a lot of the setup pieces for you and comes with a user interface for starting/stopping/restarting things and accessing the config files quickly.

Otherwise, if you want to stick with what you have, then tell us what you have installed so far and if you've followed any particular guides to get there.

It could be that the PHP code is being interpreted as HTML because the PHP interpreter isn't associated with the .php extension in the web server setup. Try viewing the source of the page and if you see PHP source code, then that's the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

rgranlundAuthor Commented:
I did that and nothing shows.  Just a blank page.  However, from the IIS side I can see the PHP Info
0
gr8gonzoConsultantCommented:
So you're using IIS - what steps did you take to install PHP as an extension for IIS?
0
rgranlundAuthor Commented:
I did not install the PHP.
0
gr8gonzoConsultantCommented:
Are you administrating the IIS server? If so, have you gone through the IIS setup steps mentioned in the PHP documentation?
0
Dave BaldwinFixer of ProblemsCommented:
I have PHP on IIS on several machines and a hosting account and it works great, lasts long time.  However, if you didn't do the install, you should contact the person 'responsible' for it and get them to fix it.  IIS 7 will be on that machine and it breaks up the server into separate sites with separate settings.  Put the phpinfo() page on there and tell them to call you when it works.
<?php
phpinfo();
?>

Open in new window

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.