REGISTRY_ERROR blue screen crash when installing software

Hi Experts,

When trying to install some VPN client software on a Windows XP machine it crashes with a blue screen REGISTRY_ERROR every time. The machine works fine and is stable otherwise. I have run a registry cleaner.
DColinAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wayne BarronAuthor, Web DeveloperCommented:
What exactly is the error that you are getting?
nobusCommented:
post the dmp here; find it in windows\minidumps
DColinAuthor Commented:
Blue screen error is REGISTRY_ERROR dump as follows:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

Loading dump file mini030615-02.dmp
----- 32 bit Kernel Mini Dump Analysis

DUMP_HEADER32:
MajorVersion        0000000f
MinorVersion        00000a28
DirectoryTableBase  0b800460
PfnDataBase         81c00000
PsLoadedModuleList  8055d720
PsActiveProcessHead 805638b8
MachineImageType    0000014c
NumberProcessors    00000004
BugCheckCode        00000051
BugCheckParameter1  00000004
BugCheckParameter2  00000001
BugCheckParameter3  e49565f8
BugCheckParameter4  000001e9
PaeEnabled          00000001
KdDebuggerDataBlock 8054d2e0
MiniDumpFields      00000dff

TRIAGE_DUMP32:
ServicePackBuild      00000300
SizeOfDump            00010000
ValidOffset           0000fffc
ContextOffset         00000320
ExceptionOffset       000007d0
MmOffset              00001068
UnloadedDriversOffset 000010a0
PrcbOffset            00001878
ProcessOffset         000024c8
ThreadOffset          00002728
CallStackOffset       00002988
SizeOfCallStack       0000091c
DriverListOffset      00003538
DriverCount           00000088
StringPoolOffset      00005d98
StringPoolSize        000012f8
BrokenDriverOffset    00000000
TriageOptions         00000041
TopOfStack            b17436e4
DebuggerDataOffset    000032a8
DebuggerDataSize      00000290
DataBlocksOffset      00007090
DataBlocksCount       00000004


Windows XP Kernel Version 2600 (Service Pack 3) MP (4 procs) Free x86 compatible

Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
Debug session time: Fri Mar 06 17:14:43 2015
System Uptime: 0 days 0:07:41
start    end        module name
804d7000 806e5000   nt             Checksum: 001F050A  Timestamp: Thu Jul 04 03:
08:15 2013 (51D4D90F)

Unloaded modules:
b1ace000 b1af9000   kmixer.sys    Timestamp: unavailable (00000000)
b23ee000 b2419000   kmixer.sys    Timestamp: unavailable (00000000)
b24e9000 b24f4000   tap0901.sys    Timestamp: unavailable (00000000)
b8759000 b875a000   drmkaud.sys    Timestamp: unavailable (00000000)
b3d52000 b3d5f000   DMusic.sys    Timestamp: unavailable (00000000)
b27d9000 b27e7000   swmidi.sys    Timestamp: unavailable (00000000)
b2419000 b243c000   aec.sys     Timestamp: unavailable (00000000)
b8606000 b8608000   splitter.sys    Timestamp: unavailable (00000000)
b85a0000 b85a4000   kbdhid.sys    Timestamp: unavailable (00000000)
b8430000 b8435000   Cdaudio.SYS    Timestamp: unavailable (00000000)
b8594000 b8597000   Sfloppy.SYS    Timestamp: unavailable (00000000)
b8420000 b8425000   Flpydisk.SYS    Timestamp: unavailable (00000000)
b8418000 b841f000   Fdc.SYS     Timestamp: unavailable (00000000)
b82d8000 b82e3000   tap0901.sys    Timestamp: unavailable (00000000)

Finished dump check

***********************************

I tried some VPN software from another company called CyberGhost. I got the following error then in blue screened again. The machine normally s stable with a good and well used WiFi internet connection. Now both of the installed VPN software is crashing my machine. What is being accessed, networkwise,  that is causing the crash?

CyberGhost.bmp
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

nobusCommented:
plse post the dmp file as asked  ) ( for more info
DColinAuthor Commented:
nobus,

Here ius the dmp file.
Mini030715-06.dmp
nobusCommented:
it points to :
 
IMAGE_NAME:  aswSP.sysIMAGE_NAME:  aswSP.sys  this is related to avast
PROCESS_NAME:  mmc.exe     --> MMC, also known as “Microsoft Management Console

so i would uninstall avast - and reinstall it, or use another AV software
more info here :  https://forum.avast.com/index.php?topic=103530.0
DColinAuthor Commented:
nobus,

I have uninstalled Avast and it crashed again, the dump is attached.

Below is a screen shot of my Network Adapters. The 'TAP-WIN32 Adapter V9' is the VPN adapter that causes the crash during installation. But now I can not even right click Properties or enable/Disable ANY of the adapters without the computer crashing even selecting right click Properties on the Network adapters heading causes a crash. Can I reinstall these adapters somehow?

NetworkAdapters.bmpMini030715-07.dmp
DColinAuthor Commented:
I have now discovered that if I try to view the properties of any piece of hardware in the Systems/Device Manager my computer crashes with a REGISTRY_ERROR blue screen. So as the VPN software tried to add the VPN Network Adapter to the device list it causes a crash. So why is the Device Manager to Registry interaction, including simply right clicking properties, causing a crash?
nobusCommented:
ok; what motherboard is this?  model plse?
then i would start by installing all drivers for it  - as the missing drivers seem to cause the problem

be aware that you may be unable to find XP drivers for the latest models of mobo's
DColinAuthor Commented:
nobus,

What drivers do you think are missing. The last time I used the Device Manager to check on a device was about two months ago when I checked my monitors properties and all was OK then. If I try to check my monitors, or any other devices, properties now the computer crashes with a REGISTRY_ERROR.
nobusCommented:
1394 -nvidia + tap adapter; but there may be lots lmore
why don't you just tell me the model - then i can look  some up
DColinAuthor Commented:
nobu,

Does this screen shot give you the information you need?

SystemInfo.bmp
If I start the computer in Safe Mode with Networking the 1394 adapter is not shown but the NVIDIA adapter is and I can Enable it without the computer crashing. If I then start the computer in Normal Mode the computer will still crash if I select Properties or try to Enable/Disable any device listed. So I don't think that it is the Network adapter drivers that are causing the crashes. It is the act of using the Device Manager Management Console that is causing the crashes.
nobusCommented:
ok, find the drivers here ; i assume 32 bit XP  http://www.gigabyte.com/products/product-page.aspx?pid=2691#dl

install ALL drivers, or verify if you have the latest

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DColinAuthor Commented:
nobus,

The drivers all installed except The RAID drivers and the Microsoft Audio driver. These would cause the same REGISTRY_ERROR crash.
nobusCommented:
that simply is not true, and your dm shows it : 1394 -nvidia  driver missing - and maybe others
did you updtae the drivers?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.